summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2021-08-30 10:21:35 +0200
committerMichael Howitz <mh@gocept.com>2021-08-30 10:21:35 +0200
commit31dc25752f7eeacf128299f721b9d0f488732cc7 (patch)
tree78b046e108863ab7b8eb09ac1afec7696962ab97 /setup.py
parenta30909b918595d41936b3bf3d549be2becd99f1d (diff)
downloadzope-security-31dc25752f7eeacf128299f721b9d0f488732cc7.tar.gz
Lint the code.
Add support for Python 3.9.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 10 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index c049a00..17204dd 100644
--- a/setup.py
+++ b/setup.py
@@ -33,10 +33,12 @@ from setuptools.command.build_ext import build_ext
from setuptools import find_packages
from setuptools import setup
+
class optional_build_ext(build_ext):
"""This class subclasses build_ext and allows
the building of C extensions to fail.
"""
+
def run(self):
try:
build_ext.run(self)
@@ -59,14 +61,17 @@ class optional_build_ext(build_ext):
print('*' * 80)
-
here = os.path.abspath(os.path.dirname(__file__))
+
+
def read(*rnames):
with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
return f.read()
# Include directories for C extensions
# Sniff the location of the headers in the package distribution
+
+
class ModuleHeaderDir(object):
def __init__(self, require_spec, where='../..'):
@@ -84,6 +89,7 @@ class ModuleHeaderDir(object):
path = resource_filename(self._require_spec, self._where)
return os.path.abspath(path)
+
include = [ModuleHeaderDir('zope.proxy')]
codeoptimization = [
@@ -127,7 +133,7 @@ TESTS_REQUIRE = [
setup(name='zope.security',
- version='5.1.2.dev0',
+ version='5.2.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Security Framework',
@@ -150,6 +156,7 @@ setup(name='zope.security',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
@@ -197,4 +204,4 @@ setup(name='zope.security',
},
include_package_data=True,
zip_safe=False,
-)
+ )