summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2021-08-30 10:13:24 +0200
committerMichael Howitz <mh@gocept.com>2021-08-30 10:13:24 +0200
commita30909b918595d41936b3bf3d549be2becd99f1d (patch)
treeefe93f9eb24005c42cdcc2f5195e0c213011926e /appveyor.yml
parent347d187367a4d96f4b9ba70c4a5f9aa4efa6197c (diff)
downloadzope-security-a30909b918595d41936b3bf3d549be2becd99f1d.tar.gz
Configuring for c-code
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml42
1 files changed, 18 insertions, 24 deletions
diff --git a/appveyor.yml b/appveyor.yml
index 532f6dd..9816396 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -1,11 +1,12 @@
-# Currently the builds use @mgedmin's Appveyor account. The PyPI token belongs
-# to zope.wheelbuilder, which is managed by @mgedmin and @dataflake.
-
+# Generated from:
+# https://github.com/zopefoundation/meta/tree/master/config/c-code
environment:
- global:
- TWINE_USERNAME: __token__
- TWINE_PASSWORD:
- secure: aoZC/+rvJKg8B5GMGIxd1YDPcIbo2kSsckCbQ6o8fhIRqSyuhX1iLm21hgDEkq2ePuyQ7+cWnNvXGactxjzA4iUS5GCOuF/E6YTvS3nGcuoQuH607wn2hngzz1p4Z+5ClFPx27vZiRAFgBoTbIo8XODHC9qFYluZ68eiwxFOiCuXK9ONEjMn8LjoaNSPJYyJO3Wr8W5oLeYG+wGcNGuYVXEk5/LSDg5n17ujpL7qsVTdVNjTwgmtnv191n2ip1Sgh1O5Xm9eG7VDZSxr/xNMpw==
+ # Currently the builds use @mgedmin's Appveyor account. The PyPI token belongs
+ # to zope.wheelbuilder, which is managed by @mgedmin and @dataflake.
+ TWINE_USERNAME: __token__
+ TWINE_PASSWORD:
+ secure: aoZC/+rvJKg8B5GMGIxd1YDPcIbo2kSsckCbQ6o8fhIRqSyuhX1iLm21hgDEkq2ePuyQ7+cWnNvXGactxjzA4iUS5GCOuF/E6YTvS3nGcuoQuH607wn2hngzz1p4Z+5ClFPx27vZiRAFgBoTbIo8XODHC9qFYluZ68eiwxFOiCuXK9ONEjMn8LjoaNSPJYyJO3Wr8W5oLeYG+wGcNGuYVXEk5/LSDg5n17ujpL7qsVTdVNjTwgmtnv191n2ip1Sgh1O5Xm9eG7VDZSxr/xNMpw==
+ ZOPE_INTERFACE_STRICT_IRO: 1
matrix:
- python: 27
@@ -18,10 +19,11 @@ environment:
- python: 37-x64
- python: 38
- python: 38-x64
- - { python: 27, PURE_PYTHON: 1 }
- - { python: 37, PURE_PYTHON: 1 }
+ - python: 39
+ - python: 39-x64
install:
+ - "SET PYTHONVERSION=%PYTHON%"
- "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
- ps: |
$env:PYTHON = "C:\\Python${env:PYTHON}"
@@ -31,31 +33,23 @@ install:
}
- ps: if (-not (Test-Path $env:PYTHON)) { throw "No $env:PYTHON" }
- echo "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x64 > "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\amd64\vcvars64.bat"
-# We need to install the C extensions that BTrees setup-requires
-# separately because we've seen problems with the BTrees build cleanup step trying
-# to delete a .pyd that was still open.
- python -m pip install -U pip
- - pip install -U setuptools
- - pip install -U persistent
- - pip install -U BTrees
- - pip install -U zope.testrunner
- - pip install -U .[test]
+ - pip install -U setuptools wheel
+ - pip install -U -e .[test]
+
+matrix:
+ fast_finish: true
build_script:
- - pip install wheel
- python -W ignore setup.py -q bdist_wheel
test_script:
- - python -m zope.testrunner --test-path=src
-
-on_success:
- - echo Build succesful!
-
+ - zope-testrunner --test-path=src
artifacts:
- path: 'dist\*.whl'
name: wheel
deploy_script:
- - ps: if ($env:APPVEYOR_REPO_TAG -eq $TRUE -and $env:PURE_PYTHON -ne 1) { pip install twine; twine upload --skip-existing dist/* }
+ - ps: if ($env:APPVEYOR_REPO_TAG -eq $TRUE) { pip install twine; twine upload --skip-existing dist\*.whl }
deploy: on