summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-04-24 06:54:36 -0500
committerJason Madden <jamadden@gmail.com>2017-04-24 08:00:59 -0500
commit9aaf59b541bc3e0616f9f9f95b6345d1a4400e68 (patch)
treea73601e4bf67de1d67fc67eb43065691c8648130 /appveyor.yml
parent6292afe78a5eee46405d982405fcc63603478504 (diff)
downloadzope-security-9aaf59b541bc3e0616f9f9f95b6345d1a4400e68.tar.gz
Fix iteration of BTrees.items() in pure-python; and 3.6 support
Also fix ``list(proxy_btree.items())`` (or a list comprehension of the same) in Python 3, which wants the ``__len__`` for a hint. This is a central place to make sure these all behave consistently. Fixes #20 Also drop pypy3 As a 3.2 implementation, it's not supported by pip anymore. There is a much more recent version, 3.5-beta, but it's not on Travis yet. The 3.3-alpha which is on Travis is a dead end.
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml11
1 files changed, 9 insertions, 2 deletions
diff --git a/appveyor.yml b/appveyor.yml
index 7bcc4c5..8ee443a 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -9,18 +9,25 @@ environment:
- python : 34-x64
- python : 35
- python : 35-x64
+ - python : 36
+ - python : 36-x64
- { python: 27, PURE_PYTHON: 1 }
- { python: 35, PURE_PYTHON: 1 }
install:
- "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
- echo "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x64 > "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\amd64\vcvars64.bat"
- - pip install -e .
+# We need to install the C extensions that BTrees setup-requires
+# separately because we've seen problems with the BTrees build cleanup step trying
+# to delete a .pyd that was still open.
+ - pip install persistent
+ - pip install BTrees
+ - pip install -e .[test]
build: false
test_script:
- - python setup.py -q test -q
+ - python -m zope.testrunner --test-path=src
on_success:
- echo Build succesful!