summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2016-06-06 10:45:01 +0300
committerMarius Gedminas <marius@gedmin.as>2016-06-06 10:45:01 +0300
commit82d9e1ecd989a10b6bbf21774bb067ae4e32402d (patch)
treeaa7ea30049ec9193c404d4fb0d1991f931c522da /appveyor.yml
parente947f88e772f02c0214a807cb5187a7fa3c1e488 (diff)
downloadzope-security-82d9e1ecd989a10b6bbf21774bb067ae4e32402d.tar.gz
Enable Appveyor CI
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml24
1 files changed, 24 insertions, 0 deletions
diff --git a/appveyor.yml b/appveyor.yml
new file mode 100644
index 0000000..b1ad55b
--- /dev/null
+++ b/appveyor.yml
@@ -0,0 +1,24 @@
+environment:
+
+ matrix:
+ - python : 27
+ - python : 27-x64
+ - python : 33
+ - python : 33-x64
+ - python : 34
+ - python : 34-x64
+ - python : 35
+ - python : 35-x64
+
+install:
+ - "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
+ - echo "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x64 > "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\amd64\vcvars64.bat"
+ - pip install -e .
+
+build: false
+
+test_script:
+ - python setup.py -q test -q
+
+on_success:
+ - echo Build succesful!