summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Vagelpohl <jens@plyp.com>2022-11-17 14:05:05 +0100
committerJens Vagelpohl <jens@plyp.com>2022-11-17 14:05:05 +0100
commiteedf59457251cee97f3abf0615568a7891760790 (patch)
tree9afb6ddecd5b9519ca2fe205ee5bed85c480468d
parent88f6c3f6b8a2298c103a6c587c5b5267a7fbaf1e (diff)
downloadzope-security-eedf59457251cee97f3abf0615568a7891760790.tar.gz
- don't build/upload macOS universal2 wheels [ci skip]
-rw-r--r--.github/workflows/tests.yml31
1 files changed, 0 insertions, 31 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index c733b53..9a7f8c9 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -190,23 +190,6 @@ jobs:
# output (pip install uses a random temporary directory, making this difficult).
python setup.py build_ext -i
python setup.py bdist_wheel
- - name: Build zope.security (macOS universal2, Python 3.8+)
- if: >
- startsWith(runner.os, 'Mac')
- && !(startsWith(matrix.python-version, 'pypy')
- || matrix.python-version == '2.7'
- || matrix.python-version == '3.5'
- || matrix.python-version == '3.6'
- || matrix.python-version == '3.7')
- env:
- MACOSX_DEPLOYMENT_TARGET: 10.9
- _PYTHON_HOST_PLATFORM: macosx-10.9-universal2
- ARCHFLAGS: -arch arm64 -arch x86_64
- run: |
- # Next, build the wheel *in place*. This helps ccache, and also lets us cache the configure
- # output (pip install uses a random temporary directory, making this difficult).
- python setup.py build_ext -i
- python setup.py bdist_wheel
- name: Build zope.security (all other versions)
if: >
!startsWith(runner.os, 'Mac')
@@ -253,20 +236,6 @@ jobs:
# on the GHA runner, which uses x86_64 architecture.
name: zope.security-${{ runner.os }}-${{ matrix.python-version }}-arm64.whl
path: dist/*arm64.whl
- - name: Upload zope.security wheel (macOS universal2)
- if: >
- startsWith(runner.os, 'Mac')
- && !(startsWith(matrix.python-version, 'pypy')
- || matrix.python-version == '2.7'
- || matrix.python-version == '3.5'
- || matrix.python-version == '3.6'
- || matrix.python-version == '3.7')
- uses: actions/upload-artifact@v3
- with:
- # The universal2 wheel is uploaded with a different name just so it
- # can be manually downloaded when desired.
- name: zope.security-${{ runner.os }}-${{ matrix.python-version }}-universal2.whl
- path: dist/*universal2.whl
- name: Upload zope.security wheel (all other platforms)
if: >
!startsWith(runner.os, 'Mac')