summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2008-02-23 01:15:51 +0000
committerTres Seaver <tseaver@palladion.com>2008-02-23 01:15:51 +0000
commitd4ec81771786e9e82e6c2abe241414db7bc591b7 (patch)
tree9a99c975e3a5a2dcc50e56c9097af922afc8f2ec
parent0b17070d67006c099092530a8d6ca5855d85d079 (diff)
downloadzope-security-d4ec81771786e9e82e6c2abe241414db7bc591b7.tar.gz
Tag 3.3.3 release.3.3.3
-rw-r--r--CHANGES.txt45
-rw-r--r--setup.py2
-rw-r--r--src/zope/security/management.py8
3 files changed, 8 insertions, 47 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 5598c6f..a1d6f36 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -3,54 +3,19 @@ CHANGES
=======
-3.4.0 - 2007/10/02
+3.3.3 (2008-02-22)
------------------
-- Updated meta-data.
-
-
-3.4.0b5 - 2007/08/15
---------------------
-
-- Bug: Fixed a circular import in the C implementation.
-
-
-3.4.0b4 - 2007/08/14
---------------------
-
-- Bug: ``zope.security.management.system_user`` had an ugly/brittle id.
-
-
-3.4.0b3 - 2007/08/14
---------------------
-
-- ``zope.security`` now works on Python 2.5
-
-- Bug: ``zope.security.management.system_user`` wasn't a valid principal
- (didn't provide IPrincipal).
-
-- Bug: Fixed inclusion of doctest to use the doctest module from
- ``zope.testing``. Now tests can be run multiple times without
- breaking. (#98250)
-
-
-3.4.0b2 - 2007/06/15
---------------------
-
- Bug: Removed stack extraction in newInteraction. When using eggs this is an
extremly expensive function. The publisher is now more than 10 times faster
when using eggs and about twice as fast with a zope trunk checkout.
-
-3.4.0b1
--------
-
-- Temporarily fixed the hidden (and accidental) dependency on zope.testing to
- become optional.
-
-Note: The releases between 3.2.0 and 3.4.0b1 where not tracked as an
+Note: The releases between 3.2.0 and 3.3.3 where not tracked as an
individual package and have been documented in the Zope 3 changelog.
+This release exists purely to backport a major performance bugfix from
+the 3.4 release line, mostly FBO Zope2.
+
3.2.0 - 2006/01/05
------------------
diff --git a/setup.py b/setup.py
index c121e8d..1af6a7f 100644
--- a/setup.py
+++ b/setup.py
@@ -22,7 +22,7 @@ def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
setup(name='zope.security',
- version = '3.4.0',
+ version = '3.3.3',
author='Zope Corporation and Contributors',
author_email='zope3-dev@zope.org',
description='Zope3 Security Architecture',
diff --git a/src/zope/security/management.py b/src/zope/security/management.py
index f058da0..5bbe6b7 100644
--- a/src/zope/security/management.py
+++ b/src/zope/security/management.py
@@ -78,17 +78,13 @@ def getInteraction():
def newInteraction(*participations):
"""Start a new interaction."""
-
-
+
if queryInteraction() is not None:
- stack = queryInteraction()._newInteraction_called_from
raise AssertionError("newInteraction called"
- " while another interaction is active:\n%s"
- % "".join(traceback.format_list(stack)))
+ " while another interaction is active.")
interaction = getSecurityPolicy()(*participations)
- interaction._newInteraction_called_from = traceback.extract_stack()
thread_local.interaction = interaction
def endInteraction():