summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Vagelpohl <jens@plyp.com>2022-11-16 12:48:36 +0100
committerJens Vagelpohl <jens@plyp.com>2022-11-16 12:48:36 +0100
commit91f84c7d08fee4a6a4a17a9937743824c352c55b (patch)
treecb12afbea623990e7a5c75a21407e9fcd45244d1
parentc2f66ea00ba3c8cb390925c900806b112b2aac31 (diff)
downloadzope-security-91f84c7d08fee4a6a4a17a9937743824c352c55b.tar.gz
- prepare release 5.6 and package cleanups5.6
-rw-r--r--.github/workflows/tests.yml31
-rw-r--r--.meta.toml3
-rw-r--r--CHANGES.rst2
-rw-r--r--README.rst25
-rw-r--r--docs/conf.py6
-rw-r--r--setup.py8
6 files changed, 58 insertions, 17 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 9a7f8c9..c733b53 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -190,6 +190,23 @@ jobs:
# output (pip install uses a random temporary directory, making this difficult).
python setup.py build_ext -i
python setup.py bdist_wheel
+ - name: Build zope.security (macOS universal2, Python 3.8+)
+ if: >
+ startsWith(runner.os, 'Mac')
+ && !(startsWith(matrix.python-version, 'pypy')
+ || matrix.python-version == '2.7'
+ || matrix.python-version == '3.5'
+ || matrix.python-version == '3.6'
+ || matrix.python-version == '3.7')
+ env:
+ MACOSX_DEPLOYMENT_TARGET: 10.9
+ _PYTHON_HOST_PLATFORM: macosx-10.9-universal2
+ ARCHFLAGS: -arch arm64 -arch x86_64
+ run: |
+ # Next, build the wheel *in place*. This helps ccache, and also lets us cache the configure
+ # output (pip install uses a random temporary directory, making this difficult).
+ python setup.py build_ext -i
+ python setup.py bdist_wheel
- name: Build zope.security (all other versions)
if: >
!startsWith(runner.os, 'Mac')
@@ -236,6 +253,20 @@ jobs:
# on the GHA runner, which uses x86_64 architecture.
name: zope.security-${{ runner.os }}-${{ matrix.python-version }}-arm64.whl
path: dist/*arm64.whl
+ - name: Upload zope.security wheel (macOS universal2)
+ if: >
+ startsWith(runner.os, 'Mac')
+ && !(startsWith(matrix.python-version, 'pypy')
+ || matrix.python-version == '2.7'
+ || matrix.python-version == '3.5'
+ || matrix.python-version == '3.6'
+ || matrix.python-version == '3.7')
+ uses: actions/upload-artifact@v3
+ with:
+ # The universal2 wheel is uploaded with a different name just so it
+ # can be manually downloaded when desired.
+ name: zope.security-${{ runner.os }}-${{ matrix.python-version }}-universal2.whl
+ path: dist/*universal2.whl
- name: Upload zope.security wheel (all other platforms)
if: >
!startsWith(runner.os, 'Mac')
diff --git a/.meta.toml b/.meta.toml
index c83bb8d..e6bc2a1 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "57e4030390098babcc18db626cc426388394c231"
+commit-id = "342271a70d886e753e5cc629e8a81b3cfab692ac"
[python]
with-appveyor = true
@@ -12,6 +12,7 @@ with-future-python = false
with-legacy-python = true
with-docs = true
with-sphinx-doctests = true
+with-macos = false
[tox]
use-flake8 = true
diff --git a/CHANGES.rst b/CHANGES.rst
index f76d2c0..83829fb 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,7 +2,7 @@
Changes
=========
-5.6 (unreleased)
+5.6 (2022-11-16)
================
- Add support for building arm64 wheels on macOS.
diff --git a/README.rst b/README.rst
index 477fab1..c8a9203 100644
--- a/README.rst
+++ b/README.rst
@@ -1,18 +1,13 @@
-===============
- zope.security
-===============
-
-.. image:: https://img.shields.io/pypi/v/zope.security.svg
- :target: https://pypi.python.org/pypi/zope.security/
- :alt: Latest release
-
-.. image:: https://img.shields.io/pypi/pyversions/zope.security.svg
- :target: https://pypi.org/project/zope.security/
- :alt: Supported Python versions
+===================
+ ``zope.security``
+===================
.. image:: https://github.com/zopefoundation/zope.security/actions/workflows/tests.yml/badge.svg
:target: https://github.com/zopefoundation/zope.security/actions/workflows/tests.yml
+.. image:: https://ci.appveyor.com/api/projects/status/github/zopefoundation/zope.security?branch=master&svg=true
+ :target: https://ci.appveyor.com/project/mgedmin/zope-security
+
.. image:: https://coveralls.io/repos/github/zopefoundation/zope.security/badge.svg?branch=master
:target: https://coveralls.io/github/zopefoundation/zope.security?branch=master
@@ -20,6 +15,14 @@
:target: https://zopesecurity.readthedocs.io/en/latest/
:alt: Documentation Status
+.. image:: https://img.shields.io/pypi/v/zope.security.svg
+ :target: https://pypi.python.org/pypi/zope.security/
+ :alt: Latest release
+
+.. image:: https://img.shields.io/pypi/pyversions/zope.security.svg
+ :target: https://pypi.org/project/zope.security/
+ :alt: Supported Python versions
+
The Security framework provides a generic mechanism to implement security
policies on Python objects.
diff --git a/docs/conf.py b/docs/conf.py
index 31497bf..f6a2968 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -259,16 +259,16 @@ texinfo_documents = [
# Example configuration for intersphinx: refer to the Python standard library.
intersphinx_mapping = {
- 'https://docs.python.org/': None,
+ 'https://docs.python.org/3/': None,
'https://zopeinterface.readthedocs.io/en/latest': None,
'https://zopeproxy.readthedocs.io/en/latest': None,
'https://zopeschema.readthedocs.io/en/latest': None,
'https://zopelocation.readthedocs.io/en/latest': None,
}
-extlinks = {'issue': ('https://github.com/zopefoundation/zope.datetime/issues/%s',
+extlinks = {'issue': ('https://github.com/zopefoundation/zope.security/issues/%s',
'issue #'),
- 'pr': ('https://github.com/zopefoundation/zope.datetime/pull/%s',
+ 'pr': ('https://github.com/zopefoundation/zope.security/pull/%s',
'pull request #')}
autodoc_default_flags = [
diff --git a/setup.py b/setup.py
index 8fae775..f519ead 100644
--- a/setup.py
+++ b/setup.py
@@ -130,7 +130,7 @@ TESTS_REQUIRE = [
setup(name='zope.security',
- version='5.6.dev0',
+ version='5.6',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Security Framework',
@@ -164,6 +164,12 @@ setup(name='zope.security',
'Framework :: Zope :: 3',
],
url='http://github.com/zopefoundation/zope.security',
+ project_urls={
+ 'Documentation': 'https://zopesecurity.readthedocs.io',
+ 'Issue Tracker': ('https://github.com/zopefoundation'
+ '/zope.security/issues'),
+ 'Sources': 'https://github.com/zopefoundation/zope.security',
+ },
license='ZPL 2.1',
packages=find_packages('src'),
package_dir={'': 'src'},