summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Vagelpohl <jens@plyp.com>2022-11-06 12:04:43 +0100
committerJens Vagelpohl <jens@plyp.com>2022-11-06 12:04:43 +0100
commit11ae69996a8144eaed372c24d3ffb8baa75c981d (patch)
tree4e999d04a824c7e23a4e16868859322303d6050b
parente5e6e3f3e62a1fb244c887d940c782e9d102a973 (diff)
downloadzope-security-11ae69996a8144eaed372c24d3ffb8baa75c981d.tar.gz
- prepare release 5.5
-rw-r--r--.github/workflows/tests.yml40
-rwxr-xr-x.manylinux-install.sh11
-rw-r--r--.meta.toml4
-rw-r--r--CHANGES.rst4
-rw-r--r--appveyor.yml6
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
7 files changed, 18 insertions, 51 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index efb9837..90a088b 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -105,7 +105,7 @@ jobs:
- "3.8"
- "3.9"
- "3.10"
- - "3.11.0-rc.1"
+ - "3.11"
os: [ubuntu-20.04, macos-latest]
exclude:
- os: macos-latest
@@ -131,7 +131,7 @@ jobs:
- name: Get pip cache dir
id: pip-cache
run: |
- echo "::set-output name=dir::$(pip cache dir)"
+ echo "dir=$(pip cache dir)" >>$GITHUB_OUTPUT
- name: pip cache
uses: actions/cache@v2
@@ -154,16 +154,6 @@ jobs:
pip install -U pip
pip install -U setuptools wheel twine cffi
- - name: Build zope.security (3.11.0-rc.1)
- if: ${{ startsWith(matrix.python-version, '3.11.0-rc.1') }}
- run: |
- # Next, build the wheel *in place*. This helps ccache, and also lets us cache the configure
- # output (pip install uses a random temporary directory, making this difficult).
- python setup.py build_ext -i
- python setup.py bdist_wheel
- # Also install it, so that we get dependencies in the (pip) cache.
- pip install -U 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"'
- pip install --pre .[test]
- name: Build zope.security (Python 3.10 on MacOS)
if: >
startsWith(runner.os, 'Mac')
@@ -210,7 +200,6 @@ jobs:
&& startsWith(github.ref, 'refs/tags')
&& startsWith(runner.os, 'Mac')
&& !startsWith(matrix.python-version, 'pypy')
- && !startsWith(matrix.python-version, '3.11.0-rc.1')
env:
TWINE_PASSWORD: ${{ secrets.TWINE_PASSWORD }}
run: |
@@ -232,7 +221,7 @@ jobs:
- "3.8"
- "3.9"
- "3.10"
- - "3.11.0-rc.1"
+ - "3.11"
os: [ubuntu-20.04, macos-latest]
exclude:
- os: macos-latest
@@ -258,7 +247,7 @@ jobs:
- name: Get pip cache dir
id: pip-cache
run: |
- echo "::set-output name=dir::$(pip cache dir)"
+ echo "dir=$(pip cache dir)" >>$GITHUB_OUTPUT
- name: pip cache
uses: actions/cache@v2
@@ -273,21 +262,7 @@ jobs:
with:
name: zope.security-${{ runner.os }}-${{ matrix.python-version }}.whl
path: dist/
- - name: Install zope.security 3.11.0-rc.1
- if: ${{ startsWith(matrix.python-version, '3.11.0-rc.1') }}
- run: |
- pip install -U wheel setuptools
- # coverage has a wheel on PyPI for a future python version which is
- # not ABI compatible with the current one, so build it from sdist:
- pip install -U --no-binary :all: coverage
- pip install -U 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"'
- # Unzip into src/ so that testrunner can find the .so files
- # when we ask it to load tests from that directory. This
- # might also save some build time?
- unzip -n dist/zope.security-*whl -d src
- pip install --pre -U -e .[test]
- name: Install zope.security
- if: ${{ !startsWith(matrix.python-version, '3.11.0-rc.1') }}
run: |
pip install -U wheel setuptools
pip install -U coverage
@@ -349,7 +324,7 @@ jobs:
- name: Get pip cache dir
id: pip-cache
run: |
- echo "::set-output name=dir::$(pip cache dir)"
+ echo "dir=$(pip cache dir)" >>$GITHUB_OUTPUT
- name: pip cache
uses: actions/cache@v2
@@ -400,7 +375,7 @@ jobs:
- name: Get pip cache dir
id: pip-cache
run: |
- echo "::set-output name=dir::$(pip cache dir)"
+ echo "dir=$(pip cache dir)" >>$GITHUB_OUTPUT
- name: pip cache
uses: actions/cache@v2
@@ -430,6 +405,7 @@ jobs:
manylinux:
runs-on: ubuntu-20.04
+ if: github.event_name != 'pull_request' || github.event.pull_request.head.repo.full_name != github.event.pull_request.base.repo.full_name
# We use a regular Python matrix entry to share as much code as possible.
strategy:
matrix:
@@ -452,7 +428,7 @@ jobs:
- name: Get pip cache dir
id: pip-cache
run: |
- echo "::set-output name=dir::$(pip cache dir)"
+ echo "dir=$(pip cache dir)" >>$GITHUB_OUTPUT
- name: pip cache
uses: actions/cache@v2
diff --git a/.manylinux-install.sh b/.manylinux-install.sh
index 75ba0a8..8e5bb9c 100755
--- a/.manylinux-install.sh
+++ b/.manylinux-install.sh
@@ -30,12 +30,12 @@ tox_env_map() {
case $1 in
*"cp27"*) echo 'py27';;
*"cp35"*) echo 'py35';;
- *"cp311"*) echo 'py311';;
*"cp36"*) echo 'py36';;
*"cp37"*) echo 'py37';;
*"cp38"*) echo 'py38';;
*"cp39"*) echo 'py39';;
*"cp310"*) echo 'py310';;
+ *"cp311"*) echo 'py311';;
*) echo 'py';;
esac
}
@@ -51,13 +51,8 @@ for PYBIN in /opt/python/*/bin; do
[[ "${PYBIN}" == *"cp38"* ]] || \
[[ "${PYBIN}" == *"cp39"* ]] || \
[[ "${PYBIN}" == *"cp310"* ]] ; then
- if [[ "${PYBIN}" == *"cp311"* ]] ; then
- "${PYBIN}/pip" install --pre -e /io/
- "${PYBIN}/pip" wheel /io/ --pre -w wheelhouse/
- else
- "${PYBIN}/pip" install -e /io/
- "${PYBIN}/pip" wheel /io/ -w wheelhouse/
- fi
+ "${PYBIN}/pip" install -e /io/
+ "${PYBIN}/pip" wheel /io/ -w wheelhouse/
if [ `uname -m` == 'aarch64' ]; then
cd /io/
${PYBIN}/pip install tox
diff --git a/.meta.toml b/.meta.toml
index 3012966..d790e6b 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,13 +2,13 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "2231265da5ee98a7d53375386c55a4b4476a73cb"
+commit-id = "b4dd6f9ffd3d6a2cde7dc70512c62d4c7ed22cd6"
[python]
with-appveyor = true
with-windows = false
with-pypy = true
-with-future-python = true
+with-future-python = false
with-legacy-python = true
with-docs = true
with-sphinx-doctests = true
diff --git a/CHANGES.rst b/CHANGES.rst
index cecf458..cc79c05 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,10 +2,10 @@
Changes
=========
-5.5 (unreleased)
+5.5 (2022-11-06)
================
-- Nothing changed yet.
+- Add support for final release of Python 3.11.
5.4 (2022-09-15)
diff --git a/appveyor.yml b/appveyor.yml
index 3afca08..10a9529 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -23,10 +23,8 @@ environment:
- python: 39-x64
- python: 310
- python: 310-x64
- # `multibuild` cannot install non-final versions as they are not on
- # ftp.python.org, so we skip Python 3.11 until its final release:
- # - python: 311
- # - python: 311-x64
+ - python: 311
+ - python: 311-x64
install:
- "SET PYTHONVERSION=%PYTHON%"
diff --git a/setup.py b/setup.py
index eea79b7..0a3a2f9 100644
--- a/setup.py
+++ b/setup.py
@@ -130,7 +130,7 @@ TESTS_REQUIRE = [
setup(name='zope.security',
- version='5.5.dev0',
+ version='5.5',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Security Framework',
diff --git a/tox.ini b/tox.ini
index d33305c..761ba12 100644
--- a/tox.ini
+++ b/tox.ini
@@ -20,9 +20,7 @@ envlist =
[testenv]
usedevelop = true
-pip_pre = py311: true
deps =
- Sphinx
setenv =
pure: PURE_PYTHON=1
!pure-!pypy-!pypy3: PURE_PYTHON=0