summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2019-04-06 07:51:36 +0200
committerGitHub <noreply@github.com>2019-04-06 07:51:36 +0200
commitf47558a726c14c32964d80cea1c55c039a096c5b (patch)
tree1da58933fcf26405e295a02ec3206b887b75aa7f
parentf6baea7eacf9572317b26a9e71cb9a55cf1e7142 (diff)
parentb2babb1c0fbfec301f0cab8334d71697622b1138 (diff)
downloadzope-security-issue-50.tar.gz
Merge branch 'master' into issue-50issue-50
-rw-r--r--appveyor.yml4
-rw-r--r--setup.py4
2 files changed, 4 insertions, 4 deletions
diff --git a/appveyor.yml b/appveyor.yml
index ec786c7..2f86bda 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -7,8 +7,6 @@ environment:
matrix:
- python: 27
- python: 27-x64
- - python: 34
- - python: 34-x64
- python: 35
- python: 35-x64
- python: 36
@@ -16,7 +14,7 @@ environment:
- python: 37
- python: 37-x64
- { python: 27, PURE_PYTHON: 1 }
- - { python: 35, PURE_PYTHON: 1 }
+ - { python: 37, PURE_PYTHON: 1 }
install:
- "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
diff --git a/setup.py b/setup.py
index 030fddc..9f6ccae 100644
--- a/setup.py
+++ b/setup.py
@@ -155,6 +155,7 @@ setup(name='zope.security',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
@@ -196,7 +197,8 @@ setup(name='zope.security',
],
'test': TESTS_REQUIRE,
'docs': [
- 'Sphinx < 2', # Version 2.0+ only supports Python 3.5+
+ 'Sphinx < 2; python_version < "3"',
+ 'Sphinx >= 2; python_version >= "3"',
'repoze.sphinx.autointerface',
],
},