summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2023-04-17 08:47:12 +0200
committerMichael Howitz <mh@gocept.com>2023-04-17 08:47:12 +0200
commit47b8699739b7c920baea52dddf9efd4358a070be (patch)
tree8d612b1a34c48bbd4861c426b5f521c58163a93d
parent7c9340441401198b3eae0b76517afde6ff1d1719 (diff)
downloadzope-security-config-with-c-code-template-7c934044.tar.gz
Add preliminary support for Python 3.12a7.config-with-c-code-template-7c934044
-rw-r--r--.github/workflows/tests.yml18
-rw-r--r--.meta.toml2
-rw-r--r--setup.cfg2
3 files changed, 11 insertions, 11 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index ff3565d..0a41e5c 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -102,7 +102,7 @@ jobs:
- "3.9"
- "3.10"
- "3.11"
- - "3.12.0-alpha.5"
+ - "3.12.0-alpha.7"
os: [ubuntu-20.04, macos-11]
exclude:
- os: macos-11
@@ -179,15 +179,15 @@ jobs:
python setup.py build_ext -i
python setup.py bdist_wheel
- - name: Install zope.security and dependencies (3.12.0-alpha.5)
- if: matrix.python-version == '3.12.0-alpha.5'
+ - name: Install zope.security and dependencies (3.12.0-alpha.7)
+ if: matrix.python-version == '3.12.0-alpha.7'
run: |
# Install to collect dependencies into the (pip) cache.
# Use "--pre" here because dependencies with support for this future
# Python release may only be available as pre-releases
pip install --pre .[test]
- name: Install zope.security and dependencies
- if: matrix.python-version != '3.12.0-alpha.5'
+ if: matrix.python-version != '3.12.0-alpha.7'
run: |
# Install to collect dependencies into the (pip) cache.
pip install .[test]
@@ -231,7 +231,7 @@ jobs:
&& startsWith(github.ref, 'refs/tags')
&& startsWith(runner.os, 'Mac')
&& !startsWith(matrix.python-version, 'pypy')
- && !startsWith(matrix.python-version, '3.12.0-alpha.5')
+ && !startsWith(matrix.python-version, '3.12.0-alpha.7')
env:
TWINE_PASSWORD: ${{ secrets.TWINE_PASSWORD }}
run: |
@@ -250,7 +250,7 @@ jobs:
- "3.9"
- "3.10"
- "3.11"
- - "3.12.0-alpha.5"
+ - "3.12.0-alpha.7"
os: [ubuntu-20.04, macos-11]
exclude:
- os: macos-11
@@ -287,8 +287,8 @@ jobs:
with:
name: zope.security-${{ runner.os }}-${{ matrix.python-version }}.whl
path: dist/
- - name: Install zope.security 3.12.0-alpha.5
- if: ${{ startsWith(matrix.python-version, '3.12.0-alpha.5') }}
+ - name: Install zope.security 3.12.0-alpha.7
+ if: ${{ startsWith(matrix.python-version, '3.12.0-alpha.7') }}
run: |
pip install -U wheel setuptools
# coverage has a wheel on PyPI for a future python version which is
@@ -302,7 +302,7 @@ jobs:
# Python release may only be available as pre-releases
pip install --pre -U -e .[test]
- name: Install zope.security
- if: ${{ !startsWith(matrix.python-version, '3.12.0-alpha.5') }}
+ if: ${{ !startsWith(matrix.python-version, '3.12.0-alpha.7') }}
run: |
pip install -U wheel setuptools
pip install -U coverage
diff --git a/.meta.toml b/.meta.toml
index f70b396..b7efa04 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "f0962ac8"
+commit-id = "fe63cb4c"
[python]
with-appveyor = true
diff --git a/setup.cfg b/setup.cfg
index 6a8093d..114487d 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -24,7 +24,7 @@ ignore =
force_single_line = True
combine_as_imports = True
sections = FUTURE,STDLIB,THIRDPARTY,ZOPE,FIRSTPARTY,LOCALFOLDER
-known_third_party = six, docutils, pkg_resources, pytz
+known_third_party = docutils, pkg_resources, pytz
known_zope =
known_first_party =
default_section = ZOPE