summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2016-04-14 14:20:46 -0400
committerTres Seaver <tseaver@palladion.com>2016-04-14 14:20:46 -0400
commit38e70f2396c584e247d3bcf072f4443e50a19e83 (patch)
tree272652f43f50378aea8d952bdae4727e92cea2b0
parentc564507028d71c1ccf186986a261432a9c2dac4c (diff)
downloadzope-security-avoid-poisoning-wheel-cache-python-pure.tar.gz
Don't use/poison global wheel cache when building w/ PURE_PYTHON.avoid-poisoning-wheel-cache-python-pure
-rw-r--r--CHANGES.rst3
-rw-r--r--tox.ini4
2 files changed, 6 insertions, 1 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index c79392f..2766bc7 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -4,6 +4,9 @@ Changes
4.1.0 (unreleased)
------------------
+- When testing ``PURE_PYTHON`` environments under ``tox``, avoid poisoning
+ the user's global wheel cache.
+
- Drop support for Python 2.6 and 3.2.
- Add support for Python 3.5.
diff --git a/tox.ini b/tox.ini
index c57c86a..40180bc 100644
--- a/tox.ini
+++ b/tox.ini
@@ -15,19 +15,21 @@ deps =
zope.proxy
zope.testrunner
commands =
- python setup.py test -q
+ python setup.py -q test -q
[testenv:py27-pure]
basepython =
python2.7
setenv =
PURE_PYTHON = 1
+ PIP_CACHE_DIR = {envdir}/.cache
[testenv:py33-pure]
basepython =
python3.3
setenv =
PURE_PYTHON = 1
+ PIP_CACHE_DIR = {envdir}/.cache
[testenv:coverage]
basepython =