summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2014-03-17 16:23:24 -0400
committerTres Seaver <tseaver@palladion.com>2014-03-17 16:23:24 -0400
commitd43c7043542827e89d16fc0e7f74a7c9202eba49 (patch)
tree4ec62af104ab673188cc1450701724800d028697
parent79b9d04452ff5acbe6a277e6d65a917d5ae34fc8 (diff)
downloadzope-schema-d43c7043542827e89d16fc0e7f74a7c9202eba49.tar.gz
Note explicit support for Python 3.4.
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py3
-rw-r--r--tox.ini2
3 files changed, 4 insertions, 3 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index c95ef07..bc56a5a 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -4,7 +4,7 @@ zope.schema Changelog
4.4.1 (unreleased)
------------------
-- Nothing changed yet.
+- Added support for Python 3.4.
4.4.0 (2014-01-22)
diff --git a/setup.py b/setup.py
index 0b7c322..b1c9fb0 100644
--- a/setup.py
+++ b/setup.py
@@ -81,7 +81,7 @@ TESTS_REQUIRE = ['zope.testing']
setup(
name='zope.schema',
- version='4.4.1.dev0',
+ version='4.4.1dev',
url='http://pypi.python.org/pypi/zope.schema',
license='ZPL 2.1',
description='zope.interface extension for defining data schemas',
@@ -105,6 +105,7 @@ setup(
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.2",
"Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Framework :: Zope3",
diff --git a/tox.ini b/tox.ini
index 574ed90..2fd7218 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,7 +3,7 @@ envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
# py26,py27,py32,jython,pypy,coverage
- py26,py27,py32,py33,pypy,coverage,docs
+ py26,py27,py32,py33,py34,pypy,coverage,docs
[testenv]
deps =