summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Bernstein <michael@fandomhome.com>2007-02-28 16:08:37 +0000
committerMichael Bernstein <michael@fandomhome.com>2007-02-28 16:08:37 +0000
commite94bf8dcf9fe83766e741acae8f8dc99ae06f5fd (patch)
treeda9f91c8a544bad67012cb315ce12332dd991166
parent86e00d1a61e829d2944fb46d20e7b607d6aba58d (diff)
downloadzope-publisher-e94bf8dcf9fe83766e741acae8f8dc99ae06f5fd.tar.gz
Buildoutification of zope.publisher, and added setuptools dependency.
-rw-r--r--bootstrap.py52
-rw-r--r--buildout.cfg9
-rw-r--r--setup.py3
3 files changed, 63 insertions, 1 deletions
diff --git a/bootstrap.py b/bootstrap.py
new file mode 100644
index 0000000..e2facc9
--- /dev/null
+++ b/bootstrap.py
@@ -0,0 +1,52 @@
+##############################################################################
+#
+# Copyright (c) 2006 Zope Corporation and Contributors.
+# All Rights Reserved.
+#
+# This software is subject to the provisions of the Zope Public License,
+# Version 2.1 (ZPL). A copy of the ZPL should accompany this distribution.
+# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY AND ALL EXPRESS OR IMPLIED
+# WARRANTIES ARE DISCLAIMED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF TITLE, MERCHANTABILITY, AGAINST INFRINGEMENT, AND FITNESS
+# FOR A PARTICULAR PURPOSE.
+#
+##############################################################################
+"""Bootstrap a buildout-based project
+
+Simply run this script in a directory containing a buildout.cfg.
+The script accepts buildout command-line options, so you can
+use the -c option to specify an alternate configuration file.
+
+$Id: bootstrap.py 72703 2007-02-20 11:49:26Z jim $
+"""
+
+import os, shutil, sys, tempfile, urllib2
+
+tmpeggs = tempfile.mkdtemp()
+
+ez = {}
+exec urllib2.urlopen('http://peak.telecommunity.com/dist/ez_setup.py'
+ ).read() in ez
+ez['use_setuptools'](to_dir=tmpeggs, download_delay=0)
+
+import pkg_resources
+
+cmd = 'from setuptools.command.easy_install import main; main()'
+if sys.platform == 'win32':
+ cmd = '"%s"' % cmd # work around spawn lamosity on windows
+
+ws = pkg_resources.working_set
+assert os.spawnle(
+ os.P_WAIT, sys.executable, sys.executable,
+ '-c', cmd, '-mqNxd', tmpeggs, 'zc.buildout',
+ dict(os.environ,
+ PYTHONPATH=
+ ws.find(pkg_resources.Requirement.parse('setuptools')).location
+ ),
+ ) == 0
+
+ws.add_entry(tmpeggs)
+ws.require('zc.buildout')
+import zc.buildout.buildout
+zc.buildout.buildout.main(sys.argv[1:] + ['bootstrap'])
+shutil.rmtree(tmpeggs)
diff --git a/buildout.cfg b/buildout.cfg
new file mode 100644
index 0000000..a5f228b
--- /dev/null
+++ b/buildout.cfg
@@ -0,0 +1,9 @@
+[buildout]
+develop = .
+parts = test
+
+find-links = http://download.zope.org/distribution/
+
+[test]
+recipe = zc.recipe.testrunner
+eggs = zope.publisher
diff --git a/setup.py b/setup.py
index b0abcf1..a678315 100644
--- a/setup.py
+++ b/setup.py
@@ -36,7 +36,8 @@ setup(name='zope.publisher',
namespace_packages=['zope',],
tests_require = ['zope.testing'],
- install_requires=['zope.component',
+ install_requires=['setuptools',
+ 'zope.component',
'zope.event',
'zope.exceptions',
'zope.i18n',