summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2022-12-15 16:27:48 +0100
committerMichael Howitz <mh@gocept.com>2022-12-15 16:31:09 +0100
commit74123ae135dc8f5e55ff72db934a7a1dbbe02b09 (patch)
treea24c5fb7698d22e4dc63a88d080713db045418ec
parentdea3d4757390d04f6a5b53e696f08d0cab5f6023 (diff)
downloadzope-publisher-master.tar.gz
Fix GHA: ubuntu-latest no longer contains Python 3.5 and 3.6HEADmaster
-rw-r--r--.github/workflows/tests.yml11
-rw-r--r--.meta.toml3
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini6
5 files changed, 14 insertions, 9 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index f9f622d..cedf24b 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -17,7 +17,7 @@ jobs:
fail-fast: false
matrix:
os:
- - ubuntu
+ - ["ubuntu", "ubuntu-20.04"]
config:
# [Python version, tox env]
- ["3.9", "lint"]
@@ -28,22 +28,23 @@ jobs:
- ["3.8", "py38"]
- ["3.9", "py39"]
- ["3.10", "py310"]
+ - ["3.11", "py311"]
- ["pypy-2.7", "pypy"]
- ["pypy-3.7", "pypy3"]
- ["3.9", "docs"]
- ["3.9", "coverage"]
- runs-on: ${{ matrix.os }}-latest
+ runs-on: ${{ matrix.os[1] }}
if: github.event_name != 'pull_request' || github.event.pull_request.head.repo.full_name != github.event.pull_request.base.repo.full_name
name: ${{ matrix.config[1] }}
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: Set up Python
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.config[0] }}
- name: Pip cache
- uses: actions/cache@v2
+ uses: actions/cache@v3
with:
path: ~/.cache/pip
key: ${{ runner.os }}-pip-${{ matrix.config[0] }}-${{ hashFiles('setup.*', 'tox.ini') }}
diff --git a/.meta.toml b/.meta.toml
index 4aeac63..dbda55f 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/pure-python
[meta]
template = "pure-python"
-commit-id = "ae61f414cfef4e129d275679c6a76dc67b1a2c11"
+commit-id = "200573eb414d2228d463da3de7d71a6d6335a704"
[python]
with-pypy = true
@@ -11,6 +11,7 @@ with-docs = true
with-sphinx-doctests = false
with-windows = false
with-future-python = false
+with-macos = false
[coverage]
fail-under = 90
diff --git a/CHANGES.rst b/CHANGES.rst
index 875689d..5113b58 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,7 @@
6.1.1 (unreleased)
==================
-- Nothing changed yet.
+- Add support for Python 3.11.
6.1.0 (2022-03-15)
diff --git a/setup.py b/setup.py
index 5f68a17..b0ad697 100644
--- a/setup.py
+++ b/setup.py
@@ -63,6 +63,7 @@ setup(
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index e39b2cc..ec3f535 100644
--- a/tox.ini
+++ b/tox.ini
@@ -11,6 +11,7 @@ envlist =
py38
py39
py310
+ py311
pypy
pypy3
docs
@@ -43,6 +44,7 @@ deps =
[testenv:isort-apply]
basepython = python3
+skip_install = true
commands_pre =
deps =
isort
@@ -68,8 +70,8 @@ deps =
commands =
mkdir -p {toxinidir}/parts/htmlcov
coverage run -m zope.testrunner --test-path=src {posargs:-vc}
- coverage html
- coverage report -m --fail-under=90
+ coverage html --ignore-errors
+ coverage report --ignore-errors --show-missing --fail-under=90
[coverage:run]
branch = True