summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini8
1 files changed, 3 insertions, 5 deletions
diff --git a/tox.ini b/tox.ini
index e01039b..16d3641 100644
--- a/tox.ini
+++ b/tox.ini
@@ -10,6 +10,7 @@ envlist =
py37,py37-pure
py38,py38-pure
py39,py39-pure
+ py310,py310-pure
pypy
pypy3
docs
@@ -18,8 +19,6 @@ envlist =
[testenv]
usedevelop = true
deps =
- # Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
- Sphinx < 4
setenv =
pure: PURE_PYTHON=1
!pure-!pypy-!pypy3: PURE_PYTHON=0
@@ -50,7 +49,8 @@ skip_install = true
deps =
flake8
check-manifest
- check-python-versions
+ check-python-versions >= 0.19.1
+ wheel
commands =
flake8 src setup.py
check-manifest
@@ -59,8 +59,6 @@ commands =
[testenv:docs]
basepython = python3
skip_install = false
-# Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
-deps = Sphinx < 4
commands_pre =
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html