summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index bf9e1a7..477219f 100644
--- a/setup.py
+++ b/setup.py
@@ -36,6 +36,7 @@ class optional_build_ext(build_ext):
"""This class subclasses build_ext and allows
the building of C extensions to fail.
"""
+
def run(self):
try:
build_ext.run(self)
@@ -103,6 +104,7 @@ setup(name='zope.proxy',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Framework :: Zope :: 3',
@@ -130,8 +132,9 @@ setup(name='zope.proxy',
'zope.testrunner',
],
'docs': [
- 'Sphinx<4', # Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it
+ # Need < 4 until repoze.sphinx.autointerface supports Sphinx 4:
+ 'Sphinx < 4',
'repoze.sphinx.autointerface',
],
},
-)
+ )