summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml2
-rw-r--r--CHANGES.rst16
-rw-r--r--setup.py4
-rw-r--r--tox.ini6
4 files changed, 13 insertions, 15 deletions
diff --git a/.travis.yml b/.travis.yml
index cb34a5b..0df748c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,9 +1,7 @@
language: python
sudo: false
python:
- - 2.6
- 2.7
- - 3.2
- 3.3
- 3.4
- 3.5
diff --git a/CHANGES.rst b/CHANGES.rst
index 2209a1b..cc90d96 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,10 +1,12 @@
Changes
=======
-4.1.7 (unreleased)
+4.2.0 (unreleased)
------------------
-- Claim support for Python 3.5.
+- Drop support for Python 2.6 and 3.2.
+
+- Add support for Python 3.5.
4.1.6 (2015-06-02)
------------------
@@ -39,7 +41,7 @@ Changes
4.1.3 (2013-03-12)
------------------
-- Fixed interface object introspection in PyPy. For some reason PyPy makes
+- Fix interface object introspection in PyPy. For some reason PyPy makes
attributes available despite the restrictive ``__slots__`` declaration.
- Add a bunch of tests surrounding interface lookup and adaptation.
@@ -63,9 +65,9 @@ Changes
4.1.0 (2012-12-19)
------------------
-- Enabled compilation of dependent modules under Py3k.
+- Enable compilation of dependent modules under Py3k.
-- Replaced use of ``PyCObject`` APIs with equivalent ``PyCapsule`` APIs,
+- Replace use of ``PyCObject`` APIs with equivalent ``PyCapsule`` APIs,
except under Python 2.6.
N.B. This change is an ABI incompatibility under Python 2.7:
@@ -104,10 +106,10 @@ Changes
- Add 'setup.py dev' alias (runs ``setup.py develop`` plus installs
``nose`` and ``coverage``).
-- Replaced deprecated ``zope.interface.implements`` usage with equivalent
+- Replace deprecated ``zope.interface.implements`` usage with equivalent
``zope.interface.implementer`` decorator.
-- Dropped support for Python 2.4 and 2.5.
+- Drop support for Python 2.4 and 2.5.
- Add Python 3.2 support.
diff --git a/setup.py b/setup.py
index 68de11b..d8860e5 100644
--- a/setup.py
+++ b/setup.py
@@ -48,7 +48,7 @@ else:
features = {'Cwrapper': Cwrapper}
setup(name='zope.proxy',
- version='4.1.7.dev0',
+ version='4.2.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Generic Transparent Proxies',
@@ -65,10 +65,8 @@ setup(name='zope.proxy',
'License :: OSI Approved :: Zope Public License',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
diff --git a/tox.ini b/tox.ini
index f593a23..e478a7b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,8 +2,8 @@
envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
-# py26,py27,py32,jython,pypy,coverage
- py26,py27,py27-pure,py32,py33,py33-pure,py34,py35,pypy,coverage,docs
+# py27,jython,pypy,coverage
+ py27,py27-pure,py33,py33-pure,py34,py35,pypy,coverage,docs
[testenv]
commands =
@@ -42,7 +42,7 @@ deps =
[testenv:docs]
basepython =
- python2.6
+ python2.7
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest