summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-04-22 11:04:45 -0500
committerJason Madden <jamadden@gmail.com>2017-04-22 11:04:45 -0500
commit6489017129d0117407c2174ca6040f71870fb229 (patch)
tree08feb4dc87114f52bd018dccdf360a3c8514f1a4 /setup.py
parent2140ad3fca812cfcb7508307d601446b21994b66 (diff)
downloadzope-proxy-6489017129d0117407c2174ca6040f71870fb229.tar.gz
Add support for Python 3.6
Also convert to zope.testrunner in tox.ini and .travis.yml because of the namespace package issue: ``` $ tox -e py36 GLOB sdist-make: //zope.proxy/setup.py py36 create: //zope.proxy/.tox/py36 py36 installdeps: .[test] py36 inst: //zope.proxy/.tox/dist/zope.proxy-4.2.1.dev0.zip py36 installed: appdirs==1.4.3,packaging==16.8,pyparsing==2.2.0,six==1.10.0,zope.component==4.3.0,zope.event==4.2.0,zope.i18nmessageid==4.0.3,zope.interface==4.4.0,zope.location==4.0.3,zope.proxy==4.2.1.dev0,zope.schema==4.4.2,zope.security==4.0.3 py36 runtests: PYTHONHASHSEED='770288004' py36 runtests: commands[0] | python setup.py -q test -q warning: no previously-included files matching '*.dll' found anywhere in distribution warning: no previously-included files matching '*.pyo' found anywhere in distribution E ====================================================================== ERROR: proxy (unittest.loader._FailedTest) ---------------------------------------------------------------------- ImportError: Failed to import test module: proxy Traceback (most recent call last): File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/unittest/loader.py", line 153, in loadTestsFromName module = __import__(module_name) File "//zope.proxy/src/zope/proxy/__init__.py", line 21, in <module> from zope.interface import moduleProvides ModuleNotFoundError: No module named 'zope.interface' ``` Also enable travis pip cache.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 0dc335d..be6ea07 100644
--- a/setup.py
+++ b/setup.py
@@ -71,6 +71,7 @@ setup(name='zope.proxy',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
"Framework :: Zope3",