summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Vagelpohl <jens@plyp.com>2022-11-17 14:03:05 +0100
committerJens Vagelpohl <jens@plyp.com>2022-11-17 14:03:05 +0100
commitf65feaccd6f44254221bea4b215ca385da187069 (patch)
tree81711f3e8b5fe408710aa52fa37e020eed24ee5b
parent1fc31f77ba7a1e78c1a9e70f472da214bf805d75 (diff)
downloadzope-proxy-f65feaccd6f44254221bea4b215ca385da187069.tar.gz
- don't build/upload macOS universal2 wheels [ci skip]
-rw-r--r--.github/workflows/tests.yml31
1 files changed, 0 insertions, 31 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 4d8b096..ec158db 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -188,23 +188,6 @@ jobs:
# output (pip install uses a random temporary directory, making this difficult).
python setup.py build_ext -i
python setup.py bdist_wheel
- - name: Build zope.proxy (macOS universal2, Python 3.8+)
- if: >
- startsWith(runner.os, 'Mac')
- && !(startsWith(matrix.python-version, 'pypy')
- || matrix.python-version == '2.7'
- || matrix.python-version == '3.5'
- || matrix.python-version == '3.6'
- || matrix.python-version == '3.7')
- env:
- MACOSX_DEPLOYMENT_TARGET: 10.9
- _PYTHON_HOST_PLATFORM: macosx-10.9-universal2
- ARCHFLAGS: -arch arm64 -arch x86_64
- run: |
- # Next, build the wheel *in place*. This helps ccache, and also lets us cache the configure
- # output (pip install uses a random temporary directory, making this difficult).
- python setup.py build_ext -i
- python setup.py bdist_wheel
- name: Build zope.proxy (all other versions)
if: >
!startsWith(runner.os, 'Mac')
@@ -251,20 +234,6 @@ jobs:
# on the GHA runner, which uses x86_64 architecture.
name: zope.proxy-${{ runner.os }}-${{ matrix.python-version }}-arm64.whl
path: dist/*arm64.whl
- - name: Upload zope.proxy wheel (macOS universal2)
- if: >
- startsWith(runner.os, 'Mac')
- && !(startsWith(matrix.python-version, 'pypy')
- || matrix.python-version == '2.7'
- || matrix.python-version == '3.5'
- || matrix.python-version == '3.6'
- || matrix.python-version == '3.7')
- uses: actions/upload-artifact@v3
- with:
- # The universal2 wheel is uploaded with a different name just so it
- # can be manually downloaded when desired.
- name: zope.proxy-${{ runner.os }}-${{ matrix.python-version }}-universal2.whl
- path: dist/*universal2.whl
- name: Upload zope.proxy wheel (all other platforms)
if: >
!startsWith(runner.os, 'Mac')