summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Vagelpohl <jens@plyp.com>2022-11-03 14:36:14 +0100
committerJens Vagelpohl <jens@plyp.com>2022-11-03 14:36:14 +0100
commitd62710bd24cbb5823f2069b45c14380bb0e2bf5f (patch)
tree94479de8ec973cb9fa0d4e36b5c39e43fad5a0ff
parent70ca5531d543ef02fd240ece6eede8c67c9fe01e (diff)
downloadzope-proxy-d62710bd24cbb5823f2069b45c14380bb0e2bf5f.tar.gz
- prepare release 4.6.04.6.0
-rw-r--r--.github/workflows/tests.yml25
-rwxr-xr-x.manylinux-install.sh11
-rw-r--r--.meta.toml4
-rw-r--r--CHANGES.rst2
-rw-r--r--appveyor.yml2
-rw-r--r--buildout.cfg2
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
8 files changed, 8 insertions, 42 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index bdecefe..62f6596 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -154,16 +154,6 @@ jobs:
pip install -U pip
pip install -U setuptools wheel twine cffi
- - name: Build zope.proxy (3.11)
- if: ${{ startsWith(matrix.python-version, '3.11') }}
- run: |
- # Next, build the wheel *in place*. This helps ccache, and also lets us cache the configure
- # output (pip install uses a random temporary directory, making this difficult).
- python setup.py build_ext -i
- python setup.py bdist_wheel
- # Also install it, so that we get dependencies in the (pip) cache.
- pip install -U 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"'
- pip install --pre .[test]
- name: Build zope.proxy (Python 3.10 on MacOS)
if: >
startsWith(runner.os, 'Mac')
@@ -210,7 +200,6 @@ jobs:
&& startsWith(github.ref, 'refs/tags')
&& startsWith(runner.os, 'Mac')
&& !startsWith(matrix.python-version, 'pypy')
- && !startsWith(matrix.python-version, '3.11')
env:
TWINE_PASSWORD: ${{ secrets.TWINE_PASSWORD }}
run: |
@@ -273,21 +262,7 @@ jobs:
with:
name: zope.proxy-${{ runner.os }}-${{ matrix.python-version }}.whl
path: dist/
- - name: Install zope.proxy 3.11
- if: ${{ startsWith(matrix.python-version, '3.11') }}
- run: |
- pip install -U wheel setuptools
- # coverage has a wheel on PyPI for a future python version which is
- # not ABI compatible with the current one, so build it from sdist:
- pip install -U --no-binary :all: coverage
- pip install -U 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"'
- # Unzip into src/ so that testrunner can find the .so files
- # when we ask it to load tests from that directory. This
- # might also save some build time?
- unzip -n dist/zope.proxy-*whl -d src
- pip install --pre -U -e .[test]
- name: Install zope.proxy
- if: ${{ !startsWith(matrix.python-version, '3.11') }}
run: |
pip install -U wheel setuptools
pip install -U coverage
diff --git a/.manylinux-install.sh b/.manylinux-install.sh
index 2c14215..c23d663 100755
--- a/.manylinux-install.sh
+++ b/.manylinux-install.sh
@@ -30,12 +30,12 @@ tox_env_map() {
case $1 in
*"cp27"*) echo 'py27';;
*"cp35"*) echo 'py35';;
- *"cp311"*) echo 'py311';;
*"cp36"*) echo 'py36';;
*"cp37"*) echo 'py37';;
*"cp38"*) echo 'py38';;
*"cp39"*) echo 'py39';;
*"cp310"*) echo 'py310';;
+ *"cp311"*) echo 'py311';;
*) echo 'py';;
esac
}
@@ -51,13 +51,8 @@ for PYBIN in /opt/python/*/bin; do
[[ "${PYBIN}" == *"cp38"* ]] || \
[[ "${PYBIN}" == *"cp39"* ]] || \
[[ "${PYBIN}" == *"cp310"* ]] ; then
- if [[ "${PYBIN}" == *"cp311"* ]] ; then
- "${PYBIN}/pip" install --pre -e /io/
- "${PYBIN}/pip" wheel /io/ --pre -w wheelhouse/
- else
- "${PYBIN}/pip" install -e /io/
- "${PYBIN}/pip" wheel /io/ -w wheelhouse/
- fi
+ "${PYBIN}/pip" install -e /io/
+ "${PYBIN}/pip" wheel /io/ -w wheelhouse/
if [ `uname -m` == 'aarch64' ]; then
cd /io/
${PYBIN}/pip install tox
diff --git a/.meta.toml b/.meta.toml
index 60df8c2..bea61b9 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,13 +2,13 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "70229255d495a945324228b50ee735cc75e01430"
+commit-id = "b4dd6f9ffd3d6a2cde7dc70512c62d4c7ed22cd6"
[python]
with-appveyor = true
with-windows = false
with-pypy = true
-with-future-python = true
+with-future-python = false
with-legacy-python = true
with-docs = true
with-sphinx-doctests = true
diff --git a/CHANGES.rst b/CHANGES.rst
index 4ed8b4d..bb07edc 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,7 +2,7 @@
Changes
=========
-4.6.0 (unreleased)
+4.6.0 (2022-11-03)
==================
- Add support for Python 3.11.
diff --git a/appveyor.yml b/appveyor.yml
index eeaf5c3..3c6ec53 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -23,8 +23,6 @@ environment:
- python: 39-x64
- python: 310
- python: 310-x64
- # `multibuild` cannot install non-final versions as they are not on
- # ftp.python.org, so we skip Python 3.11 until its final release:
- python: 311
- python: 311-x64
diff --git a/buildout.cfg b/buildout.cfg
index 4ed495f..7c0cff4 100644
--- a/buildout.cfg
+++ b/buildout.cfg
@@ -7,7 +7,7 @@ develop = .
[test]
recipe = zc.recipe.testrunner
eggs =
- zope.proxy[testing]
+ zope.proxy[test]
[test-wo-zope-security]
recipe = zc.recipe.testrunner
diff --git a/setup.py b/setup.py
index 1b28c78..c304dcc 100644
--- a/setup.py
+++ b/setup.py
@@ -80,7 +80,7 @@ else:
headers = [os.path.join('src', 'zope', 'proxy', 'proxy.h')]
setup(name='zope.proxy',
- version='4.6.0.dev0',
+ version='4.6.0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Generic Transparent Proxies',
diff --git a/tox.ini b/tox.ini
index 3767cb4..5d7d05e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -19,9 +19,7 @@ envlist =
[testenv]
usedevelop = true
-pip_pre = py311: true
deps =
- Sphinx
setenv =
pure: PURE_PYTHON=1
!pure-!pypy-!pypy3: PURE_PYTHON=0