summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2017-09-18 10:17:25 +0300
committerMarius Gedminas <marius@gedmin.as>2017-09-18 10:17:25 +0300
commitc7b23ac1cfa803a4fbb7c4a35c8ec14d8b1f0b5d (patch)
treefdd63de0ed8605dd65fe611359e593cb36d5de6a
parente5a8615ee12190aca89e5c1f9283523d8922c7a5 (diff)
downloadzope-proxy-c7b23ac1cfa803a4fbb7c4a35c8ec14d8b1f0b5d.tar.gz
Add an appveyor.yml
Needed for #24.
-rw-r--r--appveyor.yml38
1 files changed, 38 insertions, 0 deletions
diff --git a/appveyor.yml b/appveyor.yml
new file mode 100644
index 0000000..0425cc2
--- /dev/null
+++ b/appveyor.yml
@@ -0,0 +1,38 @@
+environment:
+ global:
+ TWINE_USERNAME: zope.wheelbuilder
+ TWINE_PASSWORD:
+ secure: UcdTh6W78cRLVGfKRFoa5A==
+
+ matrix:
+ - python: 27
+ - python: 27-x64
+ - python: 33
+ - python: 33-x64
+ - python: 34
+ - python: 34-x64
+ - python: 35
+ - python: 35-x64
+ - python: 36
+ - python: 36-x64
+
+install:
+ - "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
+ - echo "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x64 > "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\amd64\vcvars64.bat"
+ - pip install -e .
+
+build_script:
+ - pip install wheel
+ - python -W ignore setup.py -q bdist_wheel
+
+test_script:
+ - python setup.py test -q
+
+artifacts:
+ - path: 'dist\*.whl'
+ name: wheel
+
+deploy_script:
+ - ps: if ($env:APPVEYOR_REPO_TAG -eq $TRUE) { pip install twine; twine upload dist/* }
+
+deploy: on