summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Vagelpohl <jens@plyp.com>2022-11-16 11:30:59 +0100
committerJens Vagelpohl <jens@plyp.com>2022-11-16 11:30:59 +0100
commit997df92ed54b3db6dcc26130f7d96be95a465280 (patch)
tree5d373aa68f74dda4b559dd88ecf1f3ce88b9b717
parentcfca89816fa10220358bd17416a08857e5cbe25d (diff)
downloadzope-proxy-997df92ed54b3db6dcc26130f7d96be95a465280.tar.gz
- prepare release 4.6.14.6.1
-rw-r--r--.github/workflows/tests.yml45
-rw-r--r--.meta.toml3
-rw-r--r--CHANGES.rst2
-rw-r--r--README.rst20
-rw-r--r--setup.py8
5 files changed, 61 insertions, 17 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index c908bac..4d8b096 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -171,10 +171,6 @@ jobs:
# output (pip install uses a random temporary directory, making this difficult).
python setup.py build_ext -i
python setup.py bdist_wheel
- # Also install it, so that we get dependencies in the (pip) cache.
- pip install -U 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"'
- pip install .[test]
-
- name: Build zope.proxy (macOS arm64, Python 3.8+)
if: >
startsWith(runner.os, 'Mac')
@@ -192,10 +188,23 @@ jobs:
# output (pip install uses a random temporary directory, making this difficult).
python setup.py build_ext -i
python setup.py bdist_wheel
- # Also install it, so that we get dependencies in the (pip) cache.
- pip install -U 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"'
- pip install .[test]
-
+ - name: Build zope.proxy (macOS universal2, Python 3.8+)
+ if: >
+ startsWith(runner.os, 'Mac')
+ && !(startsWith(matrix.python-version, 'pypy')
+ || matrix.python-version == '2.7'
+ || matrix.python-version == '3.5'
+ || matrix.python-version == '3.6'
+ || matrix.python-version == '3.7')
+ env:
+ MACOSX_DEPLOYMENT_TARGET: 10.9
+ _PYTHON_HOST_PLATFORM: macosx-10.9-universal2
+ ARCHFLAGS: -arch arm64 -arch x86_64
+ run: |
+ # Next, build the wheel *in place*. This helps ccache, and also lets us cache the configure
+ # output (pip install uses a random temporary directory, making this difficult).
+ python setup.py build_ext -i
+ python setup.py bdist_wheel
- name: Build zope.proxy (all other versions)
if: >
!startsWith(runner.os, 'Mac')
@@ -209,7 +218,10 @@ jobs:
# output (pip install uses a random temporary directory, making this difficult).
python setup.py build_ext -i
python setup.py bdist_wheel
- # Also install it, so that we get dependencies in the (pip) cache.
+
+ - name: Install zope.proxy and dependencies
+ run: |
+ # Install to collect dependencies into the (pip) cache.
pip install -U 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"'
pip install .[test]
@@ -239,6 +251,20 @@ jobs:
# on the GHA runner, which uses x86_64 architecture.
name: zope.proxy-${{ runner.os }}-${{ matrix.python-version }}-arm64.whl
path: dist/*arm64.whl
+ - name: Upload zope.proxy wheel (macOS universal2)
+ if: >
+ startsWith(runner.os, 'Mac')
+ && !(startsWith(matrix.python-version, 'pypy')
+ || matrix.python-version == '2.7'
+ || matrix.python-version == '3.5'
+ || matrix.python-version == '3.6'
+ || matrix.python-version == '3.7')
+ uses: actions/upload-artifact@v3
+ with:
+ # The universal2 wheel is uploaded with a different name just so it
+ # can be manually downloaded when desired.
+ name: zope.proxy-${{ runner.os }}-${{ matrix.python-version }}-universal2.whl
+ path: dist/*universal2.whl
- name: Upload zope.proxy wheel (all other platforms)
if: >
!startsWith(runner.os, 'Mac')
@@ -322,6 +348,7 @@ jobs:
pip install -U wheel setuptools
pip install -U coverage
pip install -U 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"'
+ pip install -U 'cffi; platform_python_implementation == "CPython"'
# Unzip into src/ so that testrunner can find the .so files
# when we ask it to load tests from that directory. This
# might also save some build time?
diff --git a/.meta.toml b/.meta.toml
index 905e243..9749fc4 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "a6a0b3d5c83b07baef36cfa9c298bfa2a906039e"
+commit-id = "342271a70d886e753e5cc629e8a81b3cfab692ac"
[python]
with-appveyor = true
@@ -12,6 +12,7 @@ with-future-python = false
with-legacy-python = true
with-docs = true
with-sphinx-doctests = true
+with-macos = false
[tox]
use-flake8 = true
diff --git a/CHANGES.rst b/CHANGES.rst
index 456a2ff..4f67bf7 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,7 +2,7 @@
Changes
=========
-4.6.1 (unreleased)
+4.6.1 (2022-11-16)
==================
- Add support for building arm64 wheels on macOS.
diff --git a/README.rst b/README.rst
index 30db9ef..67d0266 100644
--- a/README.rst
+++ b/README.rst
@@ -2,17 +2,27 @@
``zope.proxy``
================
-.. image:: https://img.shields.io/pypi/v/zope.proxy.svg
- :target: https://pypi.python.org/pypi/zope.proxy/
- :alt: Latest Version
-
.. image:: https://github.com/zopefoundation/zope.proxy/actions/workflows/tests.yml/badge.svg
:target: https://github.com/zopefoundation/zope.proxy/actions/workflows/tests.yml
+.. image:: https://ci.appveyor.com/api/projects/status/github/zopefoundation/zope.proxy?branch=master&svg=true
+ :target: https://ci.appveyor.com/project/mgedmin/zope-proxy
+
+.. image:: https://coveralls.io/repos/github/zopefoundation/zope.proxy/badge.svg?branch=master
+ :target: https://coveralls.io/github/zopefoundation/zope.proxy?branch=master
+
.. image:: https://readthedocs.org/projects/zopeproxy/badge/?version=latest
- :target: http://zopeproxy.readthedocs.org/en/latest/
+ :target: https://zopeproxy.readthedocs.io/en/latest/
:alt: Documentation Status
+.. image:: https://img.shields.io/pypi/v/zope.proxy.svg
+ :target: https://pypi.org/project/zope.proxy/
+ :alt: Latest release
+
+.. image:: https://img.shields.io/pypi/pyversions/zope.proxy.svg
+ :target: https://pypi.org/project/zope.proxy/
+ :alt: Python versions
+
Proxies are special objects which serve as mostly-transparent
wrappers around another object, intervening in the apparent behavior of
the wrapped object only when necessary to apply the policy (e.g., access
diff --git a/setup.py b/setup.py
index bc58f47..e0bbbfb 100644
--- a/setup.py
+++ b/setup.py
@@ -80,7 +80,7 @@ else:
headers = [os.path.join('src', 'zope', 'proxy', 'proxy.h')]
setup(name='zope.proxy',
- version='4.6.1.dev0',
+ version='4.6.1',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Generic Transparent Proxies',
@@ -90,6 +90,11 @@ setup(name='zope.proxy',
read('CHANGES.rst')
),
url='http://github.com/zopefoundation/zope.proxy',
+ project_urls={
+ 'Documentation': 'https://zopeproxy.readthedocs.io',
+ 'Issue Tracker': 'https://github.com/zopefoundation/zope.proxy/issues',
+ 'Sources': 'https://github.com/zopefoundation/zope.proxy',
+ },
license='ZPL 2.1',
classifiers=[
'Development Status :: 5 - Production/Stable',
@@ -121,6 +126,7 @@ setup(name='zope.proxy',
},
headers=headers,
ext_modules=ext_modules,
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*',
install_requires=[
'zope.interface',
'setuptools',