summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2020-01-21 05:16:06 -0600
committerGitHub <noreply@github.com>2020-01-21 05:16:06 -0600
commit4698959600050ea07108c093ef35ec4727c0e0ea (patch)
tree0719dc35d24cbf26b671bdfe63aef53a7a6e22ed
parent9d8b17c40bd68e329b6fc8a52c41d52d247c90dc (diff)
parent1c3670350243fd643ef45543489f801790c43940 (diff)
downloadzope-proxy-4698959600050ea07108c093ef35ec4727c0e0ea.tar.gz
Merge pull request #34 from zopefoundation/deprecated-setuptools-features
Drop the use of the deprecated setuptools Features
-rw-r--r--setup.py26
1 files changed, 11 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index 5a1be61..1d3eea9 100644
--- a/setup.py
+++ b/setup.py
@@ -30,7 +30,7 @@ from distutils.errors import DistutilsPlatformError
from setuptools import Extension
from setuptools.command.build_ext import build_ext
from setuptools import setup
-from setuptools import Feature
+
class optional_build_ext(build_ext):
@@ -64,24 +64,19 @@ def read(*rnames):
return f.read()
-Cwrapper = Feature(
- "C wrapper",
- standard=True,
- headers=[os.path.join('src', 'zope', 'proxy', 'proxy.h')],
- ext_modules=[
- Extension(
- "zope.proxy._zope_proxy_proxy",
- [os.path.join('src', 'zope', 'proxy', "_zope_proxy_proxy.c")],
- ),
- ],
-)
+codeoptimization = [
+ Extension(
+ "zope.proxy._zope_proxy_proxy",
+ [os.path.join('src', 'zope', 'proxy', "_zope_proxy_proxy.c")],
+ ),
+]
# PyPy won't build the extension.
is_pypy = platform.python_implementation() == 'PyPy'
if is_pypy:
- features = {}
+ ext_modules = []
else:
- features = {'Cwrapper': Cwrapper}
+ ext_modules = codeoptimization
setup(name='zope.proxy',
version='4.3.4.dev0',
@@ -120,7 +115,8 @@ setup(name='zope.proxy',
cmdclass={
'build_ext': optional_build_ext,
},
- features=features,
+ headers=[os.path.join('src', 'zope', 'proxy', 'proxy.h')],
+ ext_modules=ext_modules,
install_requires=[
'zope.interface',
'setuptools',