summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2020-01-20 05:38:37 -0600
committerJason Madden <jamadden@gmail.com>2020-01-20 06:47:10 -0600
commit1173e599cea5c61cf61128e3470eb6e673d3d899 (patch)
tree2c844adc3a89ed049ee7923e22b5a3304370dbb4
parent9d8b17c40bd68e329b6fc8a52c41d52d247c90dc (diff)
downloadzope-proxy-1173e599cea5c61cf61128e3470eb6e673d3d899.tar.gz
Drop the use of the deprecated setuptools Features
-rw-r--r--setup.py25
1 files changed, 10 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index 5a1be61..9c14571 100644
--- a/setup.py
+++ b/setup.py
@@ -30,7 +30,7 @@ from distutils.errors import DistutilsPlatformError
from setuptools import Extension
from setuptools.command.build_ext import build_ext
from setuptools import setup
-from setuptools import Feature
+
class optional_build_ext(build_ext):
@@ -64,24 +64,19 @@ def read(*rnames):
return f.read()
-Cwrapper = Feature(
- "C wrapper",
- standard=True,
- headers=[os.path.join('src', 'zope', 'proxy', 'proxy.h')],
- ext_modules=[
- Extension(
- "zope.proxy._zope_proxy_proxy",
- [os.path.join('src', 'zope', 'proxy', "_zope_proxy_proxy.c")],
- ),
- ],
-)
+codeoptimization = [
+ Extension(
+ "zope.proxy._zope_proxy_proxy",
+ [os.path.join('src', 'zope', 'proxy', "_zope_proxy_proxy.c")],
+ ),
+]
# PyPy won't build the extension.
is_pypy = platform.python_implementation() == 'PyPy'
if is_pypy:
- features = {}
+ ext_modules = []
else:
- features = {'Cwrapper': Cwrapper}
+ ext_modules = codeoptimization
setup(name='zope.proxy',
version='4.3.4.dev0',
@@ -120,7 +115,7 @@ setup(name='zope.proxy',
cmdclass={
'build_ext': optional_build_ext,
},
- features=features,
+ ext_modules=ext_modules,
install_requires=[
'zope.interface',
'setuptools',