summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2019-11-10 11:04:52 +0200
committerMarius Gedminas <marius@gedmin.as>2019-11-10 11:04:52 +0200
commita689cef03036e5edb0d67828778a43a463a9e0e3 (patch)
tree6ea4c77259ff6ca261183c612ca0b671899e7001
parentfdc6ab2b6d1844356462357b5980c7a930619556 (diff)
downloadzope-proxy-py38.tar.gz
Add Python 3.8, drop Python 3.4py38
-rw-r--r--.travis.yml49
-rw-r--r--CHANGES.rst6
-rw-r--r--appveyor.yml13
-rw-r--r--setup.py6
-rw-r--r--tox.ini2
5 files changed, 43 insertions, 33 deletions
diff --git a/.travis.yml b/.travis.yml
index d1e7c32..084c8a7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,35 +1,36 @@
language: python
-sudo: false
python:
- - 2.7
- - 3.4
- - 3.5
- - 3.6
- - pypy
- - pypy3
-matrix:
- include:
- - python: "2.7"
- env: PURE_PYTHON=1
- - python: "3.7"
- dist: xenial
- sudo: true
+ - 2.7
+ - 3.5
+ - 3.6
+ - 3.7
+ - 3.8
+ - pypy
+ - pypy3
+
+jobs:
+ include:
+ - name: "Python: 2.7, pure (no C extensions)"
+ python: "2.7"
+ env: PURE_PYTHON=1
+
install:
- - pip install -U pip
- - pip install -U setuptools
- - pip install -U coverage coveralls
- - pip install -e .[test,docs]
+ - pip install -U pip
+ - pip install -U setuptools
+ - pip install -U coverage coveralls
+ - pip install -e .[test,docs]
+
script:
- - coverage run -m zope.testrunner --test-path=src
- - sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
- - coverage run -a `which sphinx-build` -b doctest -d docs/_build/doctrees docs docs/_build/doctest
+ - coverage run -m zope.testrunner --test-path=src
+ - sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
+ - coverage run -a -m sphinx -b doctest -d docs/_build/doctrees docs docs/_build/doctest
after_success:
- - coveralls
+ - coveralls
notifications:
- email: false
+ email: false
cache: pip
before_cache:
- - rm -f $HOME/.cache/pip/log/debug.log
+ - rm -f $HOME/.cache/pip/log/debug.log
diff --git a/CHANGES.rst b/CHANGES.rst
index 7aabc6c..52c816d 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,10 +1,12 @@
Changes
=======
-4.3.3 (unreleased)
+4.4.0 (unreleased)
------------------
-- Nothing changed yet.
+- Add support for Python 3.8.
+
+- Drop support for Python 3.4.
4.3.2 (2019-07-12)
diff --git a/appveyor.yml b/appveyor.yml
index f775534..d643125 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -7,17 +7,24 @@ environment:
matrix:
- python: 27
- python: 27-x64
- - python: 34
- - python: 34-x64
- python: 35
- python: 35-x64
- python: 36
- python: 36-x64
- python: 37
- python: 37-x64
+ - python: 38
+ - python: 38-x64
install:
- "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
+ - ps: |
+ $env:PYTHON = "C:\\Python${env:PYTHON}"
+ if (-not (Test-Path $env:PYTHON)) {
+ curl -o install_python.ps1 https://raw.githubusercontent.com/matthew-brett/multibuild/11a389d78892cf90addac8f69433d5e22bfa422a/install_python.ps1
+ .\install_python.ps1
+ }
+ - ps: if (-not (Test-Path $env:PYTHON)) { throw "No $env:PYTHON" }
- echo "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x64 > "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\amd64\vcvars64.bat"
- pip install -e .
@@ -33,6 +40,6 @@ artifacts:
name: wheel
deploy_script:
- - ps: if ($env:APPVEYOR_REPO_TAG -eq $TRUE) { pip install twine; twine upload dist/* }
+ - ps: if ($env:APPVEYOR_REPO_TAG -eq $TRUE) { pip install twine; twine upload --skip-existing dist/* }
deploy: on
diff --git a/setup.py b/setup.py
index a087cb4..d46e6a5 100644
--- a/setup.py
+++ b/setup.py
@@ -103,15 +103,15 @@ setup(name='zope.proxy',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
- "Framework :: Zope :: 3",
+ 'Framework :: Zope :: 3',
'Natural Language :: English',
- 'Operating System :: OS Independent'
+ 'Operating System :: OS Independent',
],
keywords='proxy generic transparent',
packages=['zope', 'zope.proxy'],
diff --git a/tox.ini b/tox.ini
index 590c864..682954e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py27-pure,py34,py35,py36,py36-pure,py37,pypy,coverage,docs
+ py27,py27-pure,py35,py36,py36-pure,py37,py38,pypy,coverage,docs
[testenv]
deps =