summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2020-03-16 14:09:33 +0200
committerMarius Gedminas <marius@gedmin.as>2020-03-16 14:09:33 +0200
commit4f7b7e4c4c89e72de9cfc9479253e4414b374209 (patch)
treec4ee86987c2af1c1b3096d03ae1d82aed8584e6b
parentcebf19969e2ed2334334d8794c980c0d11b26d72 (diff)
downloadzope-proxy-fix-pypy-installs.tar.gz
Stop installing C headers on PyPyfix-pypy-installs
Fixes #39.
-rw-r--r--CHANGES.rst4
-rw-r--r--setup.py5
2 files changed, 6 insertions, 3 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index f1dbe04..e5059ff 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,9 @@
4.3.5 (unreleased)
==================
-- Nothing changed yet.
+- Stop installing C header files on PyPy (which is what zope.proxy before 4.3.4
+ used to do), fixes `issue 39
+ <https://github.com/zopefoundation/zope.proxy/issues/39>`_.
4.3.4 (2020-03-13)
diff --git a/setup.py b/setup.py
index af6aeec..76514b1 100644
--- a/setup.py
+++ b/setup.py
@@ -32,7 +32,6 @@ from setuptools.command.build_ext import build_ext
from setuptools import setup
-
class optional_build_ext(build_ext):
"""This class subclasses build_ext and allows
the building of C extensions to fail.
@@ -75,8 +74,10 @@ codeoptimization = [
is_pypy = platform.python_implementation() == 'PyPy'
if is_pypy:
ext_modules = []
+ headers = []
else:
ext_modules = codeoptimization
+ headers = [os.path.join('src', 'zope', 'proxy', 'proxy.h')]
setup(name='zope.proxy',
version='4.3.5.dev0',
@@ -115,7 +116,7 @@ setup(name='zope.proxy',
cmdclass={
'build_ext': optional_build_ext,
},
- headers=[os.path.join('src', 'zope', 'proxy', 'proxy.h')],
+ headers=headers,
ext_modules=ext_modules,
install_requires=[
'zope.interface',