summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2023-04-24 09:06:01 +0200
committerGitHub <noreply@github.com>2023-04-24 09:06:01 +0200
commit566a6c89d775914b380ea3d2d625712e7964e162 (patch)
treefc4ae83a75d1dbf007598eb408c7954ac6df9883
parentc455eb43987b43e54f65bb07ed7c7bc8d893669a (diff)
downloadzope-proxy-master.tar.gz
Add preliminary support for Python 3.12a7 (#58)HEADmaster
-rw-r--r--.github/workflows/tests.yml18
-rw-r--r--.meta.toml2
-rw-r--r--setup.cfg2
3 files changed, 11 insertions, 11 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index d7d5f80..9b779dd 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -102,7 +102,7 @@ jobs:
- "3.9"
- "3.10"
- "3.11"
- - "3.12.0-alpha.5"
+ - "3.12.0-alpha.7"
os: [ubuntu-20.04, macos-11]
exclude:
- os: macos-11
@@ -178,15 +178,15 @@ jobs:
python setup.py build_ext -i
python setup.py bdist_wheel
- - name: Install zope.proxy and dependencies (3.12.0-alpha.5)
- if: matrix.python-version == '3.12.0-alpha.5'
+ - name: Install zope.proxy and dependencies (3.12.0-alpha.7)
+ if: matrix.python-version == '3.12.0-alpha.7'
run: |
# Install to collect dependencies into the (pip) cache.
# Use "--pre" here because dependencies with support for this future
# Python release may only be available as pre-releases
pip install --pre .[test]
- name: Install zope.proxy and dependencies
- if: matrix.python-version != '3.12.0-alpha.5'
+ if: matrix.python-version != '3.12.0-alpha.7'
run: |
# Install to collect dependencies into the (pip) cache.
pip install .[test]
@@ -230,7 +230,7 @@ jobs:
&& startsWith(github.ref, 'refs/tags')
&& startsWith(runner.os, 'Mac')
&& !startsWith(matrix.python-version, 'pypy')
- && !startsWith(matrix.python-version, '3.12.0-alpha.5')
+ && !startsWith(matrix.python-version, '3.12.0-alpha.7')
env:
TWINE_PASSWORD: ${{ secrets.TWINE_PASSWORD }}
run: |
@@ -249,7 +249,7 @@ jobs:
- "3.9"
- "3.10"
- "3.11"
- - "3.12.0-alpha.5"
+ - "3.12.0-alpha.7"
os: [ubuntu-20.04, macos-11]
exclude:
- os: macos-11
@@ -286,8 +286,8 @@ jobs:
with:
name: zope.proxy-${{ runner.os }}-${{ matrix.python-version }}.whl
path: dist/
- - name: Install zope.proxy 3.12.0-alpha.5
- if: ${{ startsWith(matrix.python-version, '3.12.0-alpha.5') }}
+ - name: Install zope.proxy 3.12.0-alpha.7
+ if: ${{ startsWith(matrix.python-version, '3.12.0-alpha.7') }}
run: |
pip install -U wheel setuptools
# coverage has a wheel on PyPI for a future python version which is
@@ -301,7 +301,7 @@ jobs:
# Python release may only be available as pre-releases
pip install --pre -U -e .[test]
- name: Install zope.proxy
- if: ${{ !startsWith(matrix.python-version, '3.12.0-alpha.5') }}
+ if: ${{ !startsWith(matrix.python-version, '3.12.0-alpha.7') }}
run: |
pip install -U wheel setuptools
pip install -U coverage
diff --git a/.meta.toml b/.meta.toml
index bea57f8..45b04bb 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "1514f236"
+commit-id = "fe63cb4c"
[python]
with-appveyor = true
diff --git a/setup.cfg b/setup.cfg
index 016a07e..90e4b20 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -24,7 +24,7 @@ ignore =
force_single_line = True
combine_as_imports = True
sections = FUTURE,STDLIB,THIRDPARTY,ZOPE,FIRSTPARTY,LOCALFOLDER
-known_third_party = six, docutils, pkg_resources, pytz
+known_third_party = docutils, pkg_resources, pytz
known_zope =
known_first_party =
default_section = ZOPE