summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2021-11-04 07:47:50 +0100
committerMichael Howitz <mh@gocept.com>2021-11-04 08:15:52 +0100
commitee8890dcc6b251bef4d451ceb742613ace37bfc3 (patch)
treea93ea0969eb71b889ed8199d4e7a911efae65ab1 /tox.ini
parent285490922584c1be42b5be89c00e7c8e1d972fb8 (diff)
downloadzope-pagetemplate-ee8890dcc6b251bef4d451ceb742613ace37bfc3.tar.gz
Add support for Python 3.10.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini16
1 files changed, 5 insertions, 11 deletions
diff --git a/tox.ini b/tox.ini
index bbaa8d6..77c9b01 100644
--- a/tox.ini
+++ b/tox.ini
@@ -10,6 +10,7 @@ envlist =
py37
py38
py39
+ py310
pypy
pypy3
docs
@@ -18,12 +19,9 @@ envlist =
[testenv]
usedevelop = true
deps =
- zope.testrunner
- # Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
- Sphinx < 4
commands =
zope-testrunner --test-path=src {posargs:-vc}
- sphinx-build -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
+ !py27-!pypy: sphinx-build -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
extras =
test
docs
@@ -34,7 +32,8 @@ skip_install = true
deps =
flake8
check-manifest
- check-python-versions
+ check-python-versions >= 0.19.1
+ wheel
commands =
flake8 src setup.py
check-manifest
@@ -43,8 +42,6 @@ commands =
[testenv:docs]
basepython = python3
skip_install = false
-# Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
-deps = Sphinx < 4
commands_pre =
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
@@ -57,9 +54,6 @@ allowlist_externals =
deps =
coverage
coverage-python-version
- # Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
- Sphinx < 4
- zope.testrunner
commands =
mkdir -p {toxinidir}/parts/htmlcov
coverage run -m zope.testrunner --test-path=src {posargs:-vc}
@@ -70,7 +64,7 @@ commands =
[coverage:run]
branch = True
plugins = coverage_python_version
-source = src
+source = zope.pagetemplate
[coverage:report]
precision = 2