summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorStephan Richter <stephan.richter@gmail.com>2013-02-28 13:32:52 -0500
committerStephan Richter <stephan.richter@gmail.com>2013-02-28 13:32:52 -0500
commit3318f66c771c70f6e9941b8d6ca6adce0ef846bf (patch)
tree751b6c93d83db84a926a7cf3ea0688fdad986f02 /tox.ini
parentc9f9d437b2a7b781b90bdb9f740ea30ff903adb9 (diff)
downloadzope-pagetemplate-3318f66c771c70f6e9941b8d6ca6adce0ef846bf.tar.gz
- Only allow ``zope.untrustedpython`` to be a dependency in Python 2.
- Fix buildout to work properly.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini23
1 files changed, 21 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index 0c459e6..8048286 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,11 +1,30 @@
[tox]
envlist =
- # py32 needs a py3k-compatible zope.security at the very least
py26,py27,py33
[testenv]
deps =
zope.pagetemplate[test]
-commands =
+ zope.component
+ zope.i18n
+ zope.i18nmessageid
+ zope.interface
+ zope.proxy
+ zope.security
+ zope.tal
+ zope.tales
+ zope.testing
+ zope.testrunner
+ zope.traversing
+commands =
python setup.py test -q
+[testenv:py26]
+deps =
+ {[testenv]deps}
+ zope.untrustedpython
+ RestrictedPython
+
+[testenv:py27]
+deps =
+ {[testenv:py26]deps}