summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-11-02 11:28:46 -0500
committerJason Madden <jamadden@gmail.com>2017-11-02 11:28:46 -0500
commita8bb76bc054662905d106a1a716538a00ef911b7 (patch)
treee594aa5d63ae93feda69a4113f24c71b25254d80 /setup.py
parent0aa5944a718040a77174857521ab70e5b566a4e8 (diff)
downloadzope-pagetemplate-a8bb76bc054662905d106a1a716538a00ef911b7.tar.gz
Build documents with Sphinx for RTD
Fixes #8 Run doctests with Sphinx on all versions as well.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 5 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 5e1c07d..1cd7eec 100644
--- a/setup.py
+++ b/setup.py
@@ -43,14 +43,6 @@ setup(name='zope.pagetemplate',
long_description=(
read('README.rst')
+ '\n\n' +
- '======================\n'
- 'Detailed Documentation\n' +
- '======================'
- + '\n\n' +
- read('src', 'zope', 'pagetemplate', 'architecture.txt')
- + '\n\n' +
- read('src', 'zope', 'pagetemplate', 'readme.txt')
- + '\n\n' +
read('CHANGES.rst')),
keywords="zope3 page template",
classifiers=[
@@ -72,7 +64,7 @@ setup(name='zope.pagetemplate',
'Topic :: Internet :: WWW/HTTP',
'Framework :: Zope3',
],
- url='http://github.com/zopefoundation/zope.pagetemplate',
+ url='https://github.com/zopefoundation/zope.pagetemplate',
license='ZPL 2.1',
packages=find_packages('src'),
package_dir={'': 'src'},
@@ -87,6 +79,10 @@ setup(name='zope.pagetemplate',
'untrusted:python_version == "2.7"': [
'zope.untrustedpython',
],
+ 'docs': [
+ 'Sphinx',
+ 'repoze.sphinx.autointerface',
+ ],
},
install_requires=[
'setuptools',