summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2006-04-05 05:11:03 +0000
committerTres Seaver <tseaver@palladion.com>2006-04-05 05:11:03 +0000
commit9722605da9830b5d9036f0fd6943346b01f8b38f (patch)
tree654aa51c8692217d2320acbd8ceb44e0665df55a
downloadzope-pagetemplate-9722605da9830b5d9036f0fd6943346b01f8b38f.tar.gz
Initial packaging of zope.pagetemplate (trunk).
-rw-r--r--CHANGES.txt32
-rw-r--r--INSTALL.txt83
-rw-r--r--README.txt37
-rw-r--r--setup.cfg.in6
-rw-r--r--setup.py46
5 files changed, 204 insertions, 0 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
new file mode 100644
index 0000000..400e9e0
--- /dev/null
+++ b/CHANGES.txt
@@ -0,0 +1,32 @@
+zope.pagetemplate Package Changelog
+===================================
+
+zope.pagetemplate version 3.2.1 (2006/03/26)
+--------------------------------------------
+
+- Corresponds to the verison of the zope.pagetemplate package shipped
+ as part of the Zope 3.2.1 release.
+
+zope.pagetemplate version 3.2.0 (2006/01/05)
+--------------------------------------------
+
+- Corresponds to the verison of the zope.pagetemplate package shipped
+ as part of the Zope 3.2.0 release.
+
+zope.pagetemplate version 3.1.0 (2005/10/03)
+--------------------------------------------
+
+- Corresponds to the verison of the zope.pagetemplate package shipped
+ as part of the Zope 3.1.0 release.
+
+zope.pagetemplate version 3.0.1 (2005/07/27)
+--------------------------------------------
+
+- Corresponds to the verison of the zope.pagetemplate package shipped
+ as part of the Zope X3.0.1 release.
+
+zope.pagetemplate version 3.0.0 (2004/11/07)
+--------------------------------------------
+
+- Corresponds to the verison of the zope.pagetemplate package shipped
+ as part of the Zope X3.0.0 release.
diff --git a/INSTALL.txt b/INSTALL.txt
new file mode 100644
index 0000000..10ddf98
--- /dev/null
+++ b/INSTALL.txt
@@ -0,0 +1,83 @@
+Installing This Package
+=======================
+
+Prerequisites
+-------------
+
+The installation steps below assume that you have the cool new 'setuptools'
+package installed in your Python. Here is where to get it:
+
+ $ wget http://peak.telecommunity.com/dist/ez_setup.py
+ $ /path/to/your/python ez_setup.py # req. write access to 'site-packages'
+
+
+ - Docs for EasyInstall:
+ http://peak.telecommunity.com/DevCenter/EasyInstall
+
+ - Docs for setuptools:
+ http://peak.telecommunity.com/DevCenter/setuptools
+
+ - Docs for eggs:
+ http://peak.telecommunity.com/DevCenter/PythonEggs
+
+
+Installing a Development Checkout
+---------------------------------
+
+Check out the package from subversion:
+
+ $ svn co svn+ssh://svn.zope.org/repos/main/zope.pagetemplate/trunk \
+ src/zope.pagetemplate
+ $ cd src/zope.pagetemplate
+
+Install it as a "devlopment egg" (which also installs its "hard"
+dependencies):
+
+ $ /path/to/your/python setup.py devel
+
+The installation of dependency eggs uses the 'setup.cfg' file in
+the checkout. You can supply '--find-links' on the command line to
+point it at a non-standard package repository.
+
+
+Running the Tests
+-----------------
+
+To test the package, you will also need the 'zope.testing' package, which
+can't (yet) be automatically installed. Eventually, you should be able to
+type:
+
+ $ /path/to/your/python setup.py test
+
+and have it install the "testing dependencies." Today, the workaround
+is to install it manually:
+
+ $ /path/to/easy_install --find-links="...." zope.testing
+
+You can then run the tests (finally) from the checkout directory:
+
+ $ /path/to/your/python test.py
+ Running:
+ .............
+ Ran 13 tests with 0 failures and 0 errors in 0.094 seconds.
+
+
+Installing a Source Distribution
+--------------------------------
+
+You can also install it from a source distribution:
+
+ $ /path/to/easy_install --find-links="...." -eb src zope.pagetemplate
+ $ cd src/zope.pagetemplate
+ $ /path/to/your/python setup.py devel
+
+
+Installing a Binary Egg
+-----------------------
+
+Install the package as a "binary egg" (which also installs its "hard"
+dependencies):
+
+ $ /path/to/easy_install --find-links="...." zope.pagetemplate
+
+
diff --git a/README.txt b/README.txt
new file mode 100644
index 0000000..45a6be3
--- /dev/null
+++ b/README.txt
@@ -0,0 +1,37 @@
+zope.pagetemplate Package Readme
+================================
+
+Overview
+--------
+
+Please see 'src/zope/pagetemplate/architecture.txt'.
+
+Changes
+-------
+
+See CHANGES.txt.
+
+Installation
+------------
+
+See INSTALL.txt.
+
+
+Developer Resources
+-------------------
+
+- Subversion browser:
+
+ http://svn.zope.org/zope.pagetemplate/
+
+- Read-only Subversion checkout:
+
+ $ svn co svn://svn.zope.org/repos/main/zope.pagetemplate/trunk
+
+- Writable Subversion checkout:
+
+ $ svn co svn://svn.zope.org/repos/main/zope.pagetemplate/trunk
+
+- Note that the 'src/zope/pagetemplate' package is acutally a
+ 'svn:externals' link to the corresponding package in the Zope3 trunk
+ (or to a specific tag, for released versions of the package).
diff --git a/setup.cfg.in b/setup.cfg.in
new file mode 100644
index 0000000..1196682
--- /dev/null
+++ b/setup.cfg.in
@@ -0,0 +1,6 @@
+[development]
+depends = zope.testing
+
+[egg_info]
+tag_build = .dev
+tag_svn_revision = 1
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..0aa2dcb
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,46 @@
+##############################################################################
+#
+# Copyright (c) 2006 Zope Corporation and Contributors.
+# All Rights Reserved.
+#
+# This software is subject to the provisions of the Zope Public License,
+# Version 2.1 (ZPL). A copy of the ZPL should accompany this distribution.
+# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY AND ALL EXPRESS OR IMPLIED
+# WARRANTIES ARE DISCLAIMED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF TITLE, MERCHANTABILITY, AGAINST INFRINGEMENT, AND FITNESS
+# FOR A PARTICULAR PURPOSE.
+#
+##############################################################################
+"""Setup for zope.pagetemplate package
+
+$Id$
+"""
+
+import os
+
+try:
+ from setuptools import setup, Extension
+except ImportError, e:
+ from distutils.core import setup, Extension
+
+setup(name='zope.pagetemplate',
+ version='1.0',
+ url='http://svn.zope.org/zope.pagetemplate',
+ license='ZPL 2.1',
+ description='Zope Page Templates',
+ author='Zope Corporation and Contributors',
+ author_email='zope3-dev@zope.org',
+
+ packages=['zope', 'zope.pagetemplate'],
+ package_dir = {'': os.path.join(os.path.dirname(__file__), 'src')},
+
+ namespace_packages=['zope',],
+ tests_require = ['zope.testing'],
+ install_requires=['zope.interface',
+ 'zope.tales',
+ 'zope.tal',
+ ],
+ include_package_data = True,
+
+ zip_safe = False,
+ )