summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Kolbe <jk@gocept.com>2018-10-05 13:14:25 +0200
committerJeremy Kolbe <jk@gocept.com>2018-10-05 13:14:25 +0200
commit85f6aef5ffb6c3ecef527c922fd259a8242fe64f (patch)
treebc0c57d3fb5ca161c4039271378b84e70457d986
parent8e5ae29547768546716736ab23ff9695d6a8e35e (diff)
downloadzope-pagetemplate-Python3.7support.tar.gz
Add support for Python 3.7Python3.7support
-rw-r--r--.travis.yml5
-rw-r--r--CHANGES.rst3
-rw-r--r--setup.py1
-rw-r--r--tox.ini6
4 files changed, 11 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index e770bda..b2ff47d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,6 +7,11 @@ python:
- 3.6
- pypy
- pypy3
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
install:
- pip install -U pip setuptools
- pip install -U coverage coveralls
diff --git a/CHANGES.rst b/CHANGES.rst
index c53231e..23d6267 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,8 +5,9 @@
4.3.1 (unreleased)
==================
-- Host documentation at https://zopepagetemplate.readthedocs.io/
+- Add support for Python 3.7.
+- Host documentation at https://zopepagetemplate.readthedocs.io/
4.3.0 (2017-09-04)
==================
diff --git a/setup.py b/setup.py
index 1cd7eec..c978073 100644
--- a/setup.py
+++ b/setup.py
@@ -57,6 +57,7 @@ setup(name='zope.pagetemplate',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 8a26210..3d3605b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36,pypy,pypy3,coverage,docs
+ py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
commands =
@@ -12,7 +12,7 @@ deps =
[testenv:coverage]
usedevelop = true
basepython =
- python2.7
+ python3.7
commands =
coverage run -m zope.testrunner --test-path=src []
coverage run -a -m sphinx -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
@@ -23,7 +23,7 @@ deps =
[testenv:docs]
basepython =
- python2.7
+ python3.6
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest