summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2016-03-23 17:37:22 -0400
committerTres Seaver <tseaver@palladion.com>2016-03-23 17:37:22 -0400
commit69c80655f5265ff2443d666e45f994ef0d6d2101 (patch)
tree52908efe386345f133ef3bebd73658397f4a4a6e
parent18ae43e82987d9748c0bb0fbcff78cc9075f57f6 (diff)
downloadzope-location-drop-py26-py32-support.tar.gz
Drop support for Python 2.6 and 3.2.drop-py26-py32-support
-rw-r--r--.travis.yml2
-rw-r--r--CHANGES.rst60
-rw-r--r--setup.py4
-rw-r--r--tox.ini8
4 files changed, 36 insertions, 38 deletions
diff --git a/.travis.yml b/.travis.yml
index f7501ad..2428b54 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,9 +1,7 @@
language: python
sudo: false
python:
- - 2.6
- 2.7
- - 3.2
- 3.3
- 3.4
- 3.5
diff --git a/CHANGES.rst b/CHANGES.rst
index c98bd89..2337da9 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,28 +1,30 @@
Changes
=======
-4.0.4 (unreleased)
+4.1.0 (unreleased)
------------------
+- Drop support for Python 2.6 and 3.2.
+
- Add a page to the docs on hacking ``zope.location``.
- Note additional documentation dependencies.
-- Claim support for Python 3.5.
+- Add support for Python 3.5.
4.0.3 (2014-03-19)
------------------
-- Added Python 3.4 support.
+- Add Python 3.4 support.
-- Updated ``boostrap.py`` to version 2.2.
+- Update ``boostrap.py`` to version 2.2.
4.0.2 (2013-03-11)
------------------
-- Changed the behavior of ``LocationProxy``'s ``__setattr__()`` to correctly
+- Change the behavior of ``LocationProxy``'s ``__setattr__()`` to correctly
behave when dealing with the pure Python version of the ``ProxyBase``
class. Also added a test suite that fully tests the pure Python proxy
version of the ``LocationProxy`` class.
@@ -31,12 +33,12 @@ Changes
4.0.1 (2013-02-19)
------------------
-- Added Python 3.3 support.
+- Add Python 3.3 support.
4.0.0 (2012-06-07)
------------------
-- Removed backward-compatibility imports:
+- Remove backward-compatibility imports:
- ``zope.copy.clone`` (aliased as ``zope.location.pickling.locationCopy``)
@@ -46,56 +48,56 @@ Changes
- ``zope.site.interfaces.IPossibleSite`` (aliased as
``zope.location.interfaces.IPossibleSite``).
-- Added Python 3.2 support.
+- Add Python 3.2 support.
-- Made ``zope.component`` dependency optional. Use the ``component`` extra
+- Make ``zope.component`` dependency optional. Use the ``component`` extra
to force its installation (or just require it directly). If
``zope.component`` is not present, this package defines the ``ISite``
interface itself, and omits adapter registrations from its ZCML.
-- Added support for PyPy.
+- Add support for PyPy.
-- Added support for continuous integration using ``tox`` and ``jenkins``.
+- Add support for continuous integration using ``tox`` and ``jenkins``.
-- 100% unit test coverage.
+- Bring unit test coverage to 100%.
-- Added Sphinx documentation: moved doctest examples to API reference.
+- Add Sphinx documentation: moved doctest examples to API reference.
-- Added 'setup.py docs' alias (installs ``Sphinx`` and dependencies).
+- Add 'setup.py docs' alias (installs ``Sphinx`` and dependencies).
-- Added 'setup.py dev' alias (runs ``setup.py develop`` plus installs
+- Add 'setup.py dev' alias (runs ``setup.py develop`` plus installs
``nose`` and ``coverage``).
-- Replaced deprecated ``zope.component.adapts`` usage with equivalent
+- Replace deprecated ``zope.component.adapts`` usage with equivalent
``zope.component.adapter`` decorator.
-- Replaced deprecated ``zope.interface.implements`` usage with equivalent
+- Replace deprecated ``zope.interface.implements`` usage with equivalent
``zope.interface.implementer`` decorator.
-- Dropped support for Python 2.4 and 2.5.
+- Drop support for Python 2.4 and 2.5.
3.9.1 (2011-08-22)
------------------
-- Added zcml extra as well as a test for configure.zcml.
+- Add zcml extra as well as a test for configure.zcml.
3.9.0 (2009-12-29)
------------------
-- Moved LocationCopyHook related tests to zope.copy and remove a test
+- Move LocationCopyHook related tests to zope.copy and remove a test
dependency on that package.
3.8.2 (2009-12-23)
------------------
-- Fixed a typo in the configure.zcml.
+- Fix a typo in the configure.zcml.
3.8.1 (2009-12-23)
------------------
-- Removed dependency on zope.copy: the LocationCopyHook adapter is registered
+- Remove dependency on zope.copy: the LocationCopyHook adapter is registered
only if zope.copy is available.
- Use the standard Python doctest module instead of zope.testing.doctest, which
@@ -104,35 +106,35 @@ Changes
3.8.0 (2009-12-22)
------------------
-- Adjusted to testing output caused by new zope.schema.
+- Adjust to testing output caused by new zope.schema.
3.7.1 (2009-11-18)
------------------
-- Moved the IPossibleSite and ISite interfaces to zope.component as they are
+- Move the IPossibleSite and ISite interfaces to zope.component as they are
dealing with zope.component's concept of a site, but not with location.
3.7.0 (2009-09-29)
------------------
-- Added getParent() to ILocationInfo and moved the actual implementation here
+- Add getParent() to ILocationInfo and moved the actual implementation here
from zope.traversal.api, analogous to getParents().
-- Actually removed deprecated PathPersistent class from
+- Actually remove deprecated PathPersistent class from
zope.location.pickling.
-- Moved ITraverser back to zope.traversing where it belongs conceptually. The
+- Move ITraverser back to zope.traversing where it belongs conceptually. The
interface had been moved to zope.location to invert the package
interdependency but is no longer used here.
3.6.0 (2009-08-27)
------------------
-- New feature release: deprecated locationCopy, CopyPersistent and
+- New feature release: deprecate locationCopy, CopyPersistent and
PathPersistent from zope.location.pickling. These changes were already part
of the 3.5.3 release, which was erroneously numbered as a bugfix relese.
-- Removed dependency on zope.deferredimport, directly import deprecated modules
+- Remove dependency on zope.deferredimport, directly import deprecated modules
without using it.
3.5.5 (2009-08-15)
diff --git a/setup.py b/setup.py
index c4669ed..f0b5517 100644
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,7 @@ def read(*rnames):
return text
setup(name='zope.location',
- version='4.0.4.dev0',
+ version='4.1.0.dev0',
author='Zope Corporation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Location',
@@ -44,10 +44,8 @@ setup(name='zope.location',
'License :: OSI Approved :: Zope Public License',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
diff --git a/tox.ini b/tox.ini
index a9f684e..b39c8a5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,8 +2,8 @@
envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
-# py26,py27,py32,jython,pypy,coverage
- py26,py27,py32,py33,py34,py35,pypy,pypy3,coverage,docs
+# py27,jython,pypy,coverage
+ py27,py33,py34,py35,pypy,pypy3,coverage,docs
[testenv]
commands =
@@ -27,7 +27,7 @@ deps =
[testenv:coverage]
basepython =
- python2.6
+ python2.7
commands =
# The installed version messes up nose's test discovery / coverage reporting
# So, we uninstall that from the environment, and then install the editable
@@ -48,7 +48,7 @@ deps =
[testenv:docs]
basepython =
- python2.6
+ python2.7
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest