summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2022-07-07 08:24:47 +0200
committerMichael Howitz <mh@gocept.com>2022-07-07 09:06:38 +0200
commitfc36cf4f860bcc7ac474c80aa40ecfa5f342c666 (patch)
tree7440e714e83f31845fda5241ce11222d4a3900ab
parent239dd565897703f6df4f414badfd98558f8002b6 (diff)
downloadzope-interface-fc36cf4f860bcc7ac474c80aa40ecfa5f342c666.tar.gz
Fix PyPy2 run on GHA.
-rw-r--r--.github/workflows/tests.yml19
-rw-r--r--.gitignore1
-rwxr-xr-x.manylinux-install.sh12
-rw-r--r--.meta.toml2
-rw-r--r--CHANGES.rst2
-rw-r--r--CONTRIBUTING.md23
-rw-r--r--MANIFEST.in1
-rw-r--r--appveyor.yml1
-rw-r--r--setup.cfg11
-rw-r--r--tox.ini9
10 files changed, 63 insertions, 18 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index cc350c2..78ef211 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -104,7 +104,7 @@ jobs:
- "3.8"
- "3.9"
- "3.10"
- - "3.11.0-alpha.4"
+ - "3.11.0-beta.3"
os: [ubuntu-20.04, macos-latest]
exclude:
- os: macos-latest
@@ -140,7 +140,15 @@ jobs:
restore-keys: |
${{ runner.os }}-pip-
- - name: Install Build Dependencies
+ - name: Install Build Dependencies (PyPy2)
+ if: >
+ startsWith(matrix.python-version, 'pypy-2.7')
+ run: |
+ pip install -U pip
+ pip install -U setuptools wheel twine "cffi != 1.15.1"
+ - name: Install Build Dependencies (other Python versions)
+ if: >
+ !startsWith(matrix.python-version, 'pypy-2.7')
run: |
pip install -U pip
pip install -U setuptools wheel twine cffi
@@ -153,7 +161,7 @@ jobs:
python setup.py bdist_wheel
# Also install it, so that we get dependencies in the (pip) cache.
pip install -U 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"'
- pip install .[test]
+ pip install --pre .[test]
- name: Check zope.interface build
run: |
@@ -173,7 +181,7 @@ jobs:
&& startsWith(github.ref, 'refs/tags')
&& startsWith(runner.os, 'Mac')
&& !startsWith(matrix.python-version, 'pypy')
- && !startsWith(matrix.python-version, '3.11.0-alpha.4')
+ && !startsWith(matrix.python-version, '3.11.0-beta.3')
env:
TWINE_PASSWORD: ${{ secrets.TWINE_PASSWORD }}
run: |
@@ -195,7 +203,7 @@ jobs:
- "3.8"
- "3.9"
- "3.10"
- - "3.11.0-alpha.4"
+ - "3.11.0-beta.3"
os: [ubuntu-20.04, macos-latest]
exclude:
- os: macos-latest
@@ -452,7 +460,6 @@ jobs:
if: >
github.event_name == 'push'
&& startsWith(github.ref, 'refs/tags')
- && !startsWith(matrix.python-version, '3.11.0-alpha.4')
with:
user: __token__
password: ${{ secrets.TWINE_PASSWORD }}
diff --git a/.gitignore b/.gitignore
index 20b2128..6e5e8ef 100644
--- a/.gitignore
+++ b/.gitignore
@@ -28,4 +28,5 @@ lib64
log/
parts/
pyvenv.cfg
+testing.log
var/
diff --git a/.manylinux-install.sh b/.manylinux-install.sh
index 7bb27b7..484eb00 100755
--- a/.manylinux-install.sh
+++ b/.manylinux-install.sh
@@ -37,13 +37,13 @@ for PYBIN in /opt/python/*/bin; do
[[ "${PYBIN}" == *"cp38"* ]] || \
[[ "${PYBIN}" == *"cp39"* ]] || \
[[ "${PYBIN}" == *"cp310"* ]] ; then
- "${PYBIN}/pip" install -e /io/
- "${PYBIN}/pip" wheel /io/ -w wheelhouse/
+ "${PYBIN}/pip" install --pre -e /io/
+ "${PYBIN}/pip" wheel /io/ --pre -w wheelhouse/
if [ `uname -m` == 'aarch64' ]; then
- cd /io/
- "${PYBIN}/pip" install tox
- "${PYBIN}/tox" -e py
- cd ..
+ cd /io/
+ "${PYBIN}/pip" install tox
+ "${PYBIN}/tox" -e py
+ cd ..
fi
rm -rf /io/build /io/*.egg-info
fi
diff --git a/.meta.toml b/.meta.toml
index b4ae459..593eba0 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "a326a385c9c33fdb9d01ac2bfc6111a83a003f2a"
+commit-id = "cde9741a5a0d9d04cee25cb617ee1590afebb17d"
[python]
with-appveyor = true
diff --git a/CHANGES.rst b/CHANGES.rst
index 9cb6e63..179b89d 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,7 +5,7 @@
5.5.0 (unreleased)
==================
-- Add support for Python 3.10 and 3.11 (as of 3.11.0a4).
+- Add support for Python 3.10 and 3.11 (as of 3.11.0b3).
- Add missing Trove classifier showing support for Python 3.9.
diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
new file mode 100644
index 0000000..e6d84b8
--- /dev/null
+++ b/CONTRIBUTING.md
@@ -0,0 +1,23 @@
+<!--
+Generated from:
+https://github.com/zopefoundation/meta/tree/master/config/c-code
+-->
+# Contributing to zopefoundation projects
+
+The projects under the zopefoundation GitHub organization are open source and
+welcome contributions in different forms:
+
+* bug reports
+* code improvements and bug fixes
+* documentation improvements
+* pull request reviews
+
+For any changes in the repository besides trivial typo fixes you are required
+to sign the contributor agreement. See
+https://www.zope.dev/developer/becoming-a-committer.html for details.
+
+Please visit our [Developer
+Guidelines](https://www.zope.dev/developer/guidelines.html) if you'd like to
+contribute code changes and our [guidelines for reporting
+bugs](https://www.zope.dev/developer/reporting-bugs.html) if you want to file a
+bug report.
diff --git a/MANIFEST.in b/MANIFEST.in
index 19b3bbd..44e2fc8 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,5 +1,6 @@
# Generated from:
# https://github.com/zopefoundation/meta/tree/master/config/c-code
+include *.md
include *.rst
include *.txt
include buildout.cfg
diff --git a/appveyor.yml b/appveyor.yml
index 9f14aee..4b8bf63 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -52,7 +52,6 @@ build_script:
test_script:
- python -m unittest discover -s src
-
artifacts:
- path: 'dist\*.whl'
name: wheel
diff --git a/setup.cfg b/setup.cfg
index ce0d540..8890620 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -18,3 +18,14 @@ ignore =
docs/_build/doctest/output.txt
docs/_build/html/_sources/*
docs/_build/html/_sources/api/*
+
+[isort]
+force_single_line = True
+combine_as_imports = True
+sections = FUTURE,STDLIB,THIRDPARTY,ZOPE,FIRSTPARTY,LOCALFOLDER
+known_third_party = six, docutils, pkg_resources
+known_zope =
+known_first_party =
+default_section = ZOPE
+line_length = 79
+lines_after_imports = 2
diff --git a/tox.ini b/tox.ini
index d366ac9..53213fb 100644
--- a/tox.ini
+++ b/tox.ini
@@ -19,7 +19,10 @@ envlist =
[testenv]
usedevelop = true
+pip_pre = true
deps =
+ # repoze.sphinx.autointerface does not yet support Sphinx >= 5:
+ Sphinx < 5
setenv =
pure: PURE_PYTHON=1
!pure-!pypy-!pypy3: PURE_PYTHON=0
@@ -50,13 +53,13 @@ parallel_show_output = true
[testenv:lint]
basepython = python3
skip_install = true
+commands =
+ check-manifest
+ check-python-versions
deps =
check-manifest
check-python-versions >= 0.19.1
wheel
-commands =
- check-manifest
- check-python-versions
[testenv:docs]
basepython = python3