summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2023-03-06 08:03:37 +0100
committerGitHub <noreply@github.com>2023-03-06 08:03:37 +0100
commit42f8cf51105d94991ac5ba44fcd48a557bc5ad84 (patch)
tree3a6b88658ac3a906de35ce3aa4bd5c52d4466b65
parent0dfb6cbc8861a2fbc59b56f8a30d6bb12cb5576b (diff)
downloadzope-interface-42f8cf51105d94991ac5ba44fcd48a557bc5ad84.tar.gz
Add preliminary support for Python 3.12a5. (#268)
-rw-r--r--.github/workflows/tests.yml19
-rwxr-xr-x.manylinux-install.sh11
-rw-r--r--.meta.toml4
-rw-r--r--CHANGES.rst2
-rw-r--r--appveyor.yml3
-rw-r--r--setup.cfg2
-rw-r--r--tox.ini5
7 files changed, 36 insertions, 10 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index a32a286..68d1aee 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -96,16 +96,17 @@ jobs:
fail-fast: false
matrix:
python-version:
- - "pypy-3.7"
+ - "pypy-3.9"
- "3.7"
- "3.8"
- "3.9"
- "3.10"
- "3.11"
+ - "3.12.0-alpha.5"
os: [ubuntu-20.04, macos-11]
exclude:
- os: macos-11
- python-version: "pypy-3.7"
+ python-version: "pypy-3.9"
steps:
- name: checkout
@@ -177,7 +178,15 @@ jobs:
python setup.py build_ext -i
python setup.py bdist_wheel
+ - name: Install zope.interface and dependencies (3.12.0-alpha.5)
+ if: matrix.python-version == '3.12.0-alpha.5'
+ run: |
+ # Install to collect dependencies into the (pip) cache.
+ # Use "--pre" here because dependencies with support for this future
+ # Python release may only be available as pre-releases
+ pip install --pre .[test]
- name: Install zope.interface and dependencies
+ if: matrix.python-version != '3.12.0-alpha.5'
run: |
# Install to collect dependencies into the (pip) cache.
pip install .[test]
@@ -221,6 +230,7 @@ jobs:
&& startsWith(github.ref, 'refs/tags')
&& startsWith(runner.os, 'Mac')
&& !startsWith(matrix.python-version, 'pypy')
+ && !startsWith(matrix.python-version, '3.12.0-alpha.5')
env:
TWINE_PASSWORD: ${{ secrets.TWINE_PASSWORD }}
run: |
@@ -233,16 +243,17 @@ jobs:
fail-fast: false
matrix:
python-version:
- - "pypy-3.7"
+ - "pypy-3.9"
- "3.7"
- "3.8"
- "3.9"
- "3.10"
- "3.11"
+ - "3.12.0-alpha.5"
os: [ubuntu-20.04, macos-11]
exclude:
- os: macos-11
- python-version: "pypy-3.7"
+ python-version: "pypy-3.9"
steps:
- name: checkout
diff --git a/.manylinux-install.sh b/.manylinux-install.sh
index 3da5a3b..a69608e 100755
--- a/.manylinux-install.sh
+++ b/.manylinux-install.sh
@@ -28,6 +28,7 @@ yum -y install libffi-devel
tox_env_map() {
case $1 in
+ *"cp312"*) echo 'py312';;
*"cp37"*) echo 'py37';;
*"cp38"*) echo 'py38';;
*"cp39"*) echo 'py39';;
@@ -40,13 +41,19 @@ tox_env_map() {
# Compile wheels
for PYBIN in /opt/python/*/bin; do
if \
+ [[ "${PYBIN}" == *"cp312"* ]] || \
[[ "${PYBIN}" == *"cp311"* ]] || \
[[ "${PYBIN}" == *"cp37"* ]] || \
[[ "${PYBIN}" == *"cp38"* ]] || \
[[ "${PYBIN}" == *"cp39"* ]] || \
[[ "${PYBIN}" == *"cp310"* ]] ; then
- "${PYBIN}/pip" install -e /io/
- "${PYBIN}/pip" wheel /io/ -w wheelhouse/
+ if [[ "${PYBIN}" == *"cp312"* ]] ; then
+ "${PYBIN}/pip" install --pre -e /io/
+ "${PYBIN}/pip" wheel /io/ --pre -w wheelhouse/
+ else
+ "${PYBIN}/pip" install -e /io/
+ "${PYBIN}/pip" wheel /io/ -w wheelhouse/
+ fi
if [ `uname -m` == 'aarch64' ]; then
cd /io/
${PYBIN}/pip install tox
diff --git a/.meta.toml b/.meta.toml
index ecf6737..3a1e128 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,14 +2,14 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "3c9d0741"
+commit-id = "c7a64084"
[python]
with-appveyor = true
with-pypy = true
with-sphinx-doctests = true
with-windows = false
-with-future-python = false
+with-future-python = true
with-docs = true
with-macos = false
diff --git a/CHANGES.rst b/CHANGES.rst
index 0ed2cab..6be469d 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -11,6 +11,8 @@
- Fix test deprecation warning on Python 3.11.
+- Add preliminary support for Python 3.12 as of 3.12a5.
+
- Drop:
+ `zope.interface.implements`
diff --git a/appveyor.yml b/appveyor.yml
index ae189e5..f81d541 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -15,6 +15,9 @@ environment:
- python: 39-x64
- python: 310-x64
- python: 311-x64
+ # `multibuild` cannot install non-final versions as they are not on
+ # ftp.python.org, so we skip Python 3.11 until its final release:
+ # - python: 312-x64
install:
- "SET PYTHONVERSION=%PYTHON%"
diff --git a/setup.cfg b/setup.cfg
index 202b22c..5397a2d 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -23,7 +23,7 @@ ignore =
force_single_line = True
combine_as_imports = True
sections = FUTURE,STDLIB,THIRDPARTY,ZOPE,FIRSTPARTY,LOCALFOLDER
-known_third_party = six, docutils, pkg_resources
+known_third_party = six, docutils, pkg_resources, pytz
known_zope =
known_first_party =
default_section = ZOPE
diff --git a/tox.ini b/tox.ini
index a9dbc8e..d2ce723 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
# Generated from:
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[tox]
-minversion = 3.18
+minversion = 4.0
envlist =
lint
py37,py37-pure
@@ -9,13 +9,16 @@ envlist =
py39,py39-pure
py310,py310-pure
py311,py311-pure
+ py312,py312-pure
pypy3
docs
coverage
[testenv]
usedevelop = true
+pip_pre = py312: true
deps =
+ Sphinx
setenv =
pure: PURE_PYTHON=1
!pure-!pypy3: PURE_PYTHON=0