summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2020-01-22 06:19:57 -0600
committerJason Madden <jamadden@gmail.com>2020-01-22 06:19:57 -0600
commitb928f8a53cb299f72ff60fc8e622b8e41cabad12 (patch)
treed89929c120d7f7febdbd312ec286982723e4baf8
parent35f349bb364ff47c6d617384a2c7eb4c3257be8b (diff)
downloadzope-interface-no-pure-python-build.tar.gz
Bump version as suggested in review.no-pure-python-build
Also add a line of missing whitespace.
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py2
-rw-r--r--src/zope/interface/_compat.py1
3 files changed, 3 insertions, 2 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index cb3d02f..0039191 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,7 +2,7 @@
Changes
=========
-4.7.2 (unreleased)
+4.8.0 (unreleased)
==================
- Support the ``PURE_PYTHON`` environment variable at runtime instead
diff --git a/setup.py b/setup.py
index e053bfa..d6d0e34 100644
--- a/setup.py
+++ b/setup.py
@@ -95,7 +95,7 @@ long_description = (
)
setup(name='zope.interface',
- version='4.7.2.dev0',
+ version='4.8.0.dev0',
url='https://github.com/zopefoundation/zope.interface',
license='ZPL 2.1',
description='Interfaces for Python',
diff --git a/src/zope/interface/_compat.py b/src/zope/interface/_compat.py
index c25362d..f8b7887 100644
--- a/src/zope/interface/_compat.py
+++ b/src/zope/interface/_compat.py
@@ -116,6 +116,7 @@ def _should_attempt_c_optimizations():
return False
return not _c_optimizations_ignored()
+
def _use_c_impl(py_impl, name=None, globs=None):
"""
Decorator. Given an object implemented in Python, with a name like