summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini17
1 files changed, 15 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index eb70366..36d0f34 100644
--- a/tox.ini
+++ b/tox.ini
@@ -25,8 +25,10 @@ setenv =
!pure-!pypy-!pypy3: PURE_PYTHON=0
commands =
zope-testrunner --test-path=src {posargs:-vc}
+ !py27-!pypy: sphinx-build -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
extras =
test
+ docs
[testenv:coverage]
basepython = python3
@@ -46,18 +48,29 @@ commands =
basepython = python3
skip_install = true
commands =
+ isort --check-only --diff {toxinidir}/src {toxinidir}/setup.py
+ flake8 src setup.py
check-manifest
check-python-versions
deps =
check-manifest
check-python-versions >= 0.19.1
wheel
+ flake8
+ isort
+
+[testenv:isort-apply]
+basepython = python3
+commands_pre =
+deps =
+ isort
+commands =
+ isort {toxinidir}/src {toxinidir}/setup.py []
[testenv:docs]
basepython = python3
skip_install = false
-extras =
- docs
commands_pre =
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
+ sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest