summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 2 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 3c779e4..28d5987 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,6 @@
##############################################################################
"""Setup for zope.i18nmessageid package
"""
-from __future__ import print_function
import os
import platform
@@ -96,7 +95,7 @@ class optional_build_ext(build_ext):
setup(
name='zope.i18nmessageid',
- version='5.1.2.dev0',
+ version='6.0.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Message Identifiers for internationalization',
@@ -112,11 +111,7 @@ setup(
'Intended Audience :: Developers',
'License :: OSI Approved :: Zope Public License',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
@@ -135,14 +130,7 @@ setup(
package_dir={'': 'src'},
namespace_packages=['zope'],
install_requires=['setuptools', 'six'],
- python_requires=', '.join([
- '>=2.7',
- '!=3.0.*',
- '!=3.1.*',
- '!=3.2.*',
- '!=3.3.*',
- '!=3.4.*',
- ]),
+ python_requires='>=3.7',
include_package_data=True,
test_suite='zope.i18nmessageid.tests.test_suite',
zip_safe=False,