summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorAlexander Heavner <alex@zope.com>2007-02-13 21:56:17 +0000
committerAlexander Heavner <alex@zope.com>2007-02-13 21:56:17 +0000
commit34d05ac0bb77dfa64687726c8f1024a5f52115ac (patch)
tree5e53a8bf5cd235622bea597b9d6826730d922786 /src
parentbe2d43f52db6e40b91dabac7c98a4b99ec1b3bbb (diff)
downloadzope-i18nmessageid-34d05ac0bb77dfa64687726c8f1024a5f52115ac.tar.gz
Changed the version number in setup.py and imported find_packages and used it.
Removed setup.cfg.in, INSTALL.txt, develop.py, CHANGES.txt, test.py, MANIFEST.in andn README.txt because they are no longer needed. The try, except statement in __init__.py was altered.
Diffstat (limited to 'src')
-rw-r--r--src/zope/__init__.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/zope/__init__.py b/src/zope/__init__.py
index f60ff1b..bf99a9d 100644
--- a/src/zope/__init__.py
+++ b/src/zope/__init__.py
@@ -1,7 +1,8 @@
-# namespace package boilerplate
+# this is a namespace package
try:
- __import__('pkg_resources').declare_namespace(__name__)
-except ImportError, e:
- from pkgutil import extend_path
- __path__ = extend_path(__path__, __name__)
+ import pkg_resources
+ pkg_resources.declare_namespace(__name__)
+except ImportError:
+ import pkgutil
+ __path__ = pkgutil.extend_path(__path__, __name__)