summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNathan Yergler <nathan@yergler.net>2006-02-28 15:28:51 +0000
committerNathan Yergler <nathan@yergler.net>2006-02-28 15:28:51 +0000
commite2c343630502e2b57ea7e9b6b09779aaf1109c6e (patch)
tree9b7d5b4b5b84e5cab36d6de5cf4f8b5d8a435115 /setup.py
parent5119cad48e322e217555d0a4192b7acb2fdef2f5 (diff)
downloadzope-i18nmessageid-e2c343630502e2b57ea7e9b6b09779aaf1109c6e.tar.gz
Explicitly exclude packages that are stitched in using svn:externals.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 14 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index b5b7ef7..7bd579f 100644
--- a/setup.py
+++ b/setup.py
@@ -19,21 +19,26 @@ $Id$
import os
try:
- from setuptools import setup, Extension
+ from setuptools import setup, Extension, find_packages
+ packages = find_packages('src', exclude=['zope.testing',
+ 'zope.testing.*',
+ 'zope.deprecation'])
+
except ImportException, e:
from distutils.core import setup, Extension
-
-setup(name='zope.i18nmessageid',
+ packages = ['zope', 'zope.i18nmessageid']
+
+setup(name='zope_i18nmessageid',
version='3.0',
url='http://svn.zope.org/zope.i18nmessageid',
license='ZPL 2.1',
- description='Zope 3 Interface Infrastructure',
+ description='Zope 3 i18n Message Identifier',
author='Zope Corporation and Contributors',
author_email='zope3-dev@zope.org',
- long_description='The implementation of interface definitions for Zope 3.',
+ long_description='',
- packages=["zope", "zope.i18nmessageid"],
+ packages=packages,
package_dir = {'': 'src'},
ext_modules=[Extension("zope.i18nmessageid._zope_i18nmessageid_message",
@@ -42,8 +47,10 @@ setup(name='zope.i18nmessageid',
]),
],
+ namespace_packages=['zope',],
tests_require = ['zope_testing'],
- requires=['zope_deprecation'],
+ install_requires=['zope_deprecation'],
include_package_data = True,
+
zip_safe = False,
)