summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2012-04-06 22:49:15 +0000
committerTres Seaver <tseaver@palladion.com>2012-04-06 22:49:15 +0000
commit51f4a73ca1d4a57b5216f2db95bcf1185c59e93b (patch)
tree01ba519e8474b4f49ac336976d3daecedbe5f8c8 /setup.py
parentcafec8e412895af5f49ae95ba2b436d0d04b218d (diff)
downloadzope-i18nmessageid-51f4a73ca1d4a57b5216f2db95bcf1185c59e93b.tar.gz
Removed use of '2to3' and associated fixers when installing under Py3k.
The code is now in a "compatible subset" which supports Python 2.6, 2.7, and 3.2, including PyPy 1.8 (the version compatible with the 2.7 language spec).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 0 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index a2b4e17..091ce1a 100644
--- a/setup.py
+++ b/setup.py
@@ -55,11 +55,6 @@ if not is_pypy and not is_jython:
# and defeats JIT opportunities).
extra['features'] = {'codeoptimization':codeoptimization}
-if sys.version_info >= (3,):
- extra['use_2to3'] = True
- extra['convert_2to3_doctests'] = ['src/zope/i18nmessageid/messages.txt',
- ]
-
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()