summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorJens Vagelpohl <jens@plyp.com>2022-11-06 11:28:36 +0000
committerGitHub <noreply@github.com>2022-11-06 11:28:36 +0000
commit5148500f402b8eccb6dc19fa223c9ea9060f8425 (patch)
tree6b1f8bc53ff0384336482f016a44cc0c5f3b7027 /appveyor.yml
parent85d9b50f1302e4bc85055a46ced8071f53e8318e (diff)
parentcb6def05fdea2b2c40bcc154a159cfae0ed46b92 (diff)
downloadzope-i18nmessageid-5148500f402b8eccb6dc19fa223c9ea9060f8425.tar.gz
Merge pull request #32 from zopefoundation/configure-with-c-code
Update with meta/config and add support for Python 3.9, 3.10 and 3.11
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml27
1 files changed, 16 insertions, 11 deletions
diff --git a/appveyor.yml b/appveyor.yml
index f0a6c96..2311d21 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -1,11 +1,6 @@
-# Currently the builds use @mgedmin's Appveyor account. The PyPI token belongs
-# to zope.wheelbuilder, which is managed by @mgedmin and @dataflake.
-
+# Generated from:
+# https://github.com/zopefoundation/meta/tree/master/config/c-code
environment:
- global:
- TWINE_USERNAME: __token__
- TWINE_PASSWORD:
- secure: aoZC/+rvJKg8B5GMGIxd1VZ0Oxtmc0lPMiqT2wHP5qBRoZf6tEB7n9u7uCIifcAX1IWsLCRF7DKWvvCQTFJL5HcQvXFQSnEuXvdMT/utFFx9eCCy+Cu+WuWkasGCG+gx9uhMTe01mixi8yujgVj894Xjdv5YyNH2dPeqV5kInTzYrOmKZs1FTvKTlYZNHyYWRnYhyaLBn4FmmeuXuFcd5o05jkaa2dnerW85F3sr7mWbCgL4GpEQ59rYX34Cl4EdEXw+IViTyFWJuZp+k9GCUnzxAmA+vlfoSbZ6JfvTLaU=
matrix:
- python: 27
@@ -18,8 +13,15 @@ environment:
- python: 37-x64
- python: 38
- python: 38-x64
+ - python: 39
+ - python: 39-x64
+ - python: 310
+ - python: 310-x64
+ - python: 311
+ - python: 311-x64
install:
+ - "SET PYTHONVERSION=%PYTHON%"
- "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
- ps: |
$env:PYTHON = "C:\\Python${env:PYTHON}"
@@ -29,20 +31,23 @@ install:
}
- ps: if (-not (Test-Path $env:PYTHON)) { throw "No $env:PYTHON" }
- echo "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x64 > "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\amd64\vcvars64.bat"
- - pip install -e .[test]
+ - python -m pip install -U pip
+ - pip install -U setuptools wheel
+ - pip install -U -e .[test]
+
+matrix:
+ fast_finish: true
build_script:
- - pip install -U setuptools wheel
- python -W ignore setup.py -q bdist_wheel
test_script:
- zope-testrunner --test-path=src
-
artifacts:
- path: 'dist\*.whl'
name: wheel
deploy_script:
- - ps: if ($env:APPVEYOR_REPO_TAG -eq $TRUE) { pip install twine; twine upload --skip-existing dist/* }
+ - ps: if ($env:APPVEYOR_REPO_TAG -eq $TRUE) { pip install twine; twine upload --skip-existing dist\*.whl }
deploy: on