summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2017-09-21 14:32:37 +0300
committerMarius Gedminas <marius@gedmin.as>2017-09-21 14:32:37 +0300
commitf69a256465d17d19f781d748ed39920f7e2ddd83 (patch)
tree1c8299e11f4756a9f6dc7dac36ff8aa21d74e895
parent9632d5a792405cd01fda4b81c518ae84af0d53ba (diff)
downloadzope-i18nmessageid-f69a256465d17d19f781d748ed39920f7e2ddd83.tar.gz
Add an appveyor.yml
Fixes #8.
-rw-r--r--appveyor.yml38
1 files changed, 38 insertions, 0 deletions
diff --git a/appveyor.yml b/appveyor.yml
new file mode 100644
index 0000000..0425cc2
--- /dev/null
+++ b/appveyor.yml
@@ -0,0 +1,38 @@
+environment:
+ global:
+ TWINE_USERNAME: zope.wheelbuilder
+ TWINE_PASSWORD:
+ secure: UcdTh6W78cRLVGfKRFoa5A==
+
+ matrix:
+ - python: 27
+ - python: 27-x64
+ - python: 33
+ - python: 33-x64
+ - python: 34
+ - python: 34-x64
+ - python: 35
+ - python: 35-x64
+ - python: 36
+ - python: 36-x64
+
+install:
+ - "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
+ - echo "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x64 > "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\amd64\vcvars64.bat"
+ - pip install -e .
+
+build_script:
+ - pip install wheel
+ - python -W ignore setup.py -q bdist_wheel
+
+test_script:
+ - python setup.py test -q
+
+artifacts:
+ - path: 'dist\*.whl'
+ name: wheel
+
+deploy_script:
+ - ps: if ($env:APPVEYOR_REPO_TAG -eq $TRUE) { pip install twine; twine upload dist/* }
+
+deploy: on