summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2018-08-09 19:00:13 +0300
committerGitHub <noreply@github.com>2018-08-09 19:00:13 +0300
commitd1c39f4bb953e23571ffa82e2d34cdc1076a280d (patch)
tree3e6381920587ae69deee43d30702cbb6cdc4cf9a
parent9608463dd44c05a6aa811feafb411182b5099b9c (diff)
parent92a3a238e4b17ef4944744830261d073332b4c78 (diff)
downloadzope-i18nmessageid-d1c39f4bb953e23571ffa82e2d34cdc1076a280d.tar.gz
Merge pull request #11 from zopefoundation/py37
Add support for Python 3.7
-rw-r--r--.travis.yml10
-rw-r--r--CHANGES.rst7
-rw-r--r--appveyor.yml4
-rw-r--r--setup.py27
-rw-r--r--tox.ini2
5 files changed, 32 insertions, 18 deletions
diff --git a/.travis.yml b/.travis.yml
index b6b3d84..d674f54 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,11 +2,15 @@ language: python
sudo: false
python:
- 2.7
- - 3.3
- 3.4
- 3.5
- 3.6
- - pypy-5.4.1
+ - pypy
+matrix:
+ include:
+ - python: 3.7
+ dist: xenial
+ sudo: true
script:
- coverage run -m zope.testrunner --test-path=src --auto-color --auto-progress
@@ -24,4 +28,4 @@ install:
cache: pip
before_cache:
- - rm -f $HOME/.cache/pip/log/debug.log
+ - rm -f $HOME/.cache/pip/log/debug.log
diff --git a/CHANGES.rst b/CHANGES.rst
index bc1e3ff..d867b20 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,12 +1,17 @@
Changes
=======
-4.1.1 (unreleased)
+4.2.0 (unreleased)
------------------
- Fix the possibility of a rare crash in the C extension when deallocating items. See
https://github.com/zopefoundation/zope.i18nmessageid/issues/7
+- Drop support for Python 3.3.
+
+- Add support for Python 3.7.
+
+
4.1.0 (2017-05-02)
------------------
diff --git a/appveyor.yml b/appveyor.yml
index 0425cc2..f775534 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -7,14 +7,14 @@ environment:
matrix:
- python: 27
- python: 27-x64
- - python: 33
- - python: 33-x64
- python: 34
- python: 34-x64
- python: 35
- python: 35-x64
- python: 36
- python: 36-x64
+ - python: 37
+ - python: 37-x64
install:
- "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
diff --git a/setup.py b/setup.py
index 8d57d48..27add7d 100644
--- a/setup.py
+++ b/setup.py
@@ -37,27 +37,30 @@ codeoptimization_c = os.path.join('src', 'zope', 'i18nmessageid',
"_zope_i18nmessageid_message.c")
codeoptimization = Feature(
"Optional code optimizations",
- standard = True,
- ext_modules = [Extension(
+ standard=True,
+ ext_modules=[Extension(
"zope.i18nmessageid._zope_i18nmessageid_message",
[os.path.normcase(codeoptimization_c)]
)])
extra = {
- 'extras_require': {'testing': ['nose', 'coverage'],
- 'docs': ['Sphinx'],
- },
+ 'extras_require': {
+ 'testing': ['nose', 'coverage'],
+ 'docs': ['Sphinx'],
+ },
}
if not is_pypy and not is_jython:
# Jython cannot build the C optimizations, while on PyPy they are
# anti-optimizations (the C extension compatibility layer is known-slow,
# and defeats JIT opportunities).
- extra['features'] = {'codeoptimization':codeoptimization}
+ extra['features'] = {'codeoptimization': codeoptimization}
+
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+
class optional_build_ext(build_ext):
"""This class subclasses build_ext and allows
the building of C extensions to fail.
@@ -94,8 +97,10 @@ class optional_build_ext(build_ext):
sys.stderr.write(str(e) + '\n')
sys.stderr.write('*' * 80 + '\n')
-setup(name='zope.i18nmessageid',
- version='4.1.1.dev0',
+
+setup(
+ name='zope.i18nmessageid',
+ version='4.2.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Message Identifiers for internationalization',
@@ -114,10 +119,10 @@ setup(name='zope.i18nmessageid',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
'Natural Language :: English',
@@ -129,11 +134,11 @@ setup(name='zope.i18nmessageid',
url='http://pypi.python.org/pypi/zope.i18nmessageid',
packages=find_packages('src'),
package_dir={'': 'src'},
- namespace_packages=['zope',],
+ namespace_packages=['zope'],
install_requires=['setuptools'],
include_package_data=True,
test_suite='zope.i18nmessageid.tests.test_suite',
zip_safe=False,
- cmdclass={'build_ext':optional_build_ext},
+ cmdclass={'build_ext': optional_build_ext},
**extra
)
diff --git a/tox.ini b/tox.ini
index 0f644e3..5498583 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py33,py34,py35,py36,pypy,pypy3,coverage,docs
+ py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
deps =