summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2016-03-23 21:49:13 -0400
committerTres Seaver <tseaver@palladion.com>2016-03-23 21:49:13 -0400
commitacd6d5c3e922aed93ca59fb4e7f1570d640c49b4 (patch)
treebe0b7d9fd5cef33ec2f842d432526c704595aec1
parentd9cbf22d3789326e68fd0834f3887554f4030e67 (diff)
parent276f81e67c693939d61ad6184b9073d74278d254 (diff)
downloadzope-i18nmessageid-acd6d5c3e922aed93ca59fb4e7f1570d640c49b4.tar.gz
Merge pull request #3 from zopefoundation/drop-py26-py32-support
Drop support for Python 2.6 and 3.2.
-rw-r--r--.travis.yml2
-rw-r--r--CHANGES.rst50
-rw-r--r--setup.py4
-rw-r--r--tox.ini2
4 files changed, 28 insertions, 30 deletions
diff --git a/.travis.yml b/.travis.yml
index 4f69fb2..4847904 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,9 +1,7 @@
language: python
sudo: false
python:
- - 2.6
- 2.7
- - 3.2
- 3.3
- 3.4
- 3.5
diff --git a/CHANGES.rst b/CHANGES.rst
index 9b4771c..eec874a 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,50 +1,52 @@
Changes
=======
-4.0.4 (unreleased)
+4.1.0 (unreleased)
------------------
-- Claim support for Python 3.5.
+- Drop support for Python 2.6 and 3.2.
+
+- Add support for Python 3.5.
4.0.3 (2014-03-19)
------------------
-- Added support for Python 3.4.
+- Add support for Python 3.4.
-- Updated ``boostrap.py`` to version 2.2.
+- Update ``boostrap.py`` to version 2.2.
4.0.2 (2012-12-31)
------------------
-- Fleshed out PyPI Trove classifiers.
+- Flesh out PyPI Trove classifiers.
4.0.1 (2012-11-21)
------------------
-- Added support for Python 3.3.
+- Add support for Python 3.3.
4.0.0 (2012-05-16)
------------------
-- Automated build of Sphinx HTML docs and running doctest snippets via tox.
+- Automate generation of Sphinx HTML docs and running doctest snippets via tox.
-- Removed use of '2to3' and associated fixers when installing under Py3k.
+- Remove use of '2to3' and associated fixers when installing under Py3k.
The code is now in a "compatible subset" which supports Python 2.6, 2.7,
and 3.2, including PyPy 1.8 (the version compatible with the 2.7 language
spec).
-- 100% unit test coverage.
+- Bring unit test coverage to 100%.
- Move doctest examples into Sphinx documentation.
-- Dropped explicit support for Python 2.4 / 2.5 / 3.1.
+- Drop explicit support for Python 2.4 / 2.5 / 3.1.
-- Added explicit support for PyPy.
+- Add explicit support for PyPy.
-- Added 'setup.py dev' alias (runs ``setup.py develop`` plus installs
+- Add 'setup.py dev' alias (runs ``setup.py develop`` plus installs
``nose`` and ``coverage``).
-- Added 'setup.py docs' alias (installs ``Sphinx`` and dependencies).
+- Add 'setup.py docs' alias (installs ``Sphinx`` and dependencies).
3.6.1 (2011-07-20)
@@ -57,7 +59,7 @@ Changes
- Python 3 support.
-- Don't attempt to compile C extensions on PyPy or Jython.
+- Suppress compiling C extensions on PyPy or Jython.
- Add a tox.ini (see http://tox.readthedocs.org/en/latest/) for easier
automated testing.
@@ -65,7 +67,7 @@ Changes
3.5.3 (2010-08-10)
------------------
-- Made compilation of C extension optional again; 3.5.1 broke this
+- Make compilation of C extension optional again; 3.5.1 broke this
inasmuch as this package become unusable on non-CPython platforms.
Making the compilation of the C extension optional again implied
removing ``setup.py`` code added in 3.5.1 which made the C extension
@@ -79,27 +81,27 @@ Changes
3.5.2 (2010-04-30)
------------------
-- Removed use of 'zope.testing.doctestunit' in favor of stdlib's 'doctest.
+- Remove use of 'zope.testing.doctestunit' in favor of stdlib's 'doctest.
3.5.1 (2010-04-10)
------------------
- LP #257657 / 489529: Fix memory leak in C extension.
-- Fixed the compilation of the C extension with python 2.6: refactored it as a
+- Fix the compilation of the C extension with python 2.6: refactored it as a
setuptools Feature.
3.5.0 (2009-06-27)
------------------
-- Made compilation of C extension optional.
+- Make compilation of C extension optional.
-- Added support to bootstrap on Jython.
+- Add support to bootstrap on Jython.
-- Changed package's mailing list address from zope3-dev at zope.org to
+- Change package's mailing list address from zope3-dev at zope.org to
zope-dev at zope.org, because zope3-dev is now retired.
-- Reformatted change log to common formatting style.
+- Reformat change log to common formatting style.
- Update package description and docs a little.
@@ -113,7 +115,7 @@ Changes
3.4.2 (2007-09-25)
------------------
-- Moved the ``ZopeMessageFactory`` from ``zope.app.i18n`` to this package.
+- Move the ``ZopeMessageFactory`` from ``zope.app.i18n`` to this package.
3.4.0 (2007-07-19)
------------------
@@ -128,9 +130,9 @@ Changes
- Corresponds to the verison of the zope.i18nmessageid package shipped as
part of the Zope 3.2.0 release.
-- Implemented 'zope.i18nmessageid.message' as a C extension.
+- Implement 'zope.i18nmessageid.message' as a C extension.
-- Deprecated 'zope.i18nmessageid.messageid' APIs ('MessageID',
+- Deprecate 'zope.i18nmessageid.messageid' APIs ('MessageID',
'MessageIDFactory') in favor of replacements in 'zope.i18nmessageid.message'
('Message', 'MessageFactory'). Deprecated items are scheduled for removal
in Zope 3.3.
diff --git a/setup.py b/setup.py
index 9e86fb6..e5c991a 100644
--- a/setup.py
+++ b/setup.py
@@ -95,7 +95,7 @@ class optional_build_ext(build_ext):
sys.stderr.write('*' * 80 + '\n')
setup(name='zope.i18nmessageid',
- version = '4.0.4.dev0',
+ version = '4.1.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Message Identifiers for internationalization',
@@ -112,10 +112,8 @@ setup(name='zope.i18nmessageid',
'License :: OSI Approved :: Zope Public License',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
diff --git a/tox.ini b/tox.ini
index 73bf7f2..3bf1484 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py26,py27,py32,py33,py34,py35,pypy,pypy3,coverage,docs
+ py27,py33,py34,py35,pypy,pypy3,coverage,docs
[testenv]
commands =