summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Howitz <mh@gocept.com>2023-03-23 08:05:03 +0100
committerGitHub <noreply@github.com>2023-03-23 08:05:03 +0100
commita55a1ac372fa5e8c0cf0d3dd6cd112acdba7c135 (patch)
treed577446a059585769858e5cea8c67ac3e2095719
parent4ce834ea770da57d7f9bbd0ea7f6e939e1969db2 (diff)
downloadzope-i18nmessageid-a55a1ac372fa5e8c0cf0d3dd6cd112acdba7c135.tar.gz
Try out Python 3.12a5. (#35)
-rw-r--r--.github/workflows/tests.yml34
-rwxr-xr-x.manylinux-install.sh11
-rw-r--r--.meta.toml4
-rw-r--r--CHANGES.rst2
-rw-r--r--appveyor.yml3
-rw-r--r--docs/narr.rst32
-rw-r--r--setup.cfg2
-rw-r--r--tox.ini5
8 files changed, 67 insertions, 26 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 7fb3bee..76cf4fa 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -96,16 +96,17 @@ jobs:
fail-fast: false
matrix:
python-version:
- - "pypy-3.7"
+ - "pypy-3.9"
- "3.7"
- "3.8"
- "3.9"
- "3.10"
- "3.11"
+ - "3.12.0-alpha.5"
os: [ubuntu-20.04, macos-11]
exclude:
- os: macos-11
- python-version: "pypy-3.7"
+ python-version: "pypy-3.9"
steps:
- name: checkout
@@ -177,7 +178,15 @@ jobs:
python setup.py build_ext -i
python setup.py bdist_wheel
+ - name: Install zope.i18nmessageid and dependencies (3.12.0-alpha.5)
+ if: matrix.python-version == '3.12.0-alpha.5'
+ run: |
+ # Install to collect dependencies into the (pip) cache.
+ # Use "--pre" here because dependencies with support for this future
+ # Python release may only be available as pre-releases
+ pip install --pre .[test]
- name: Install zope.i18nmessageid and dependencies
+ if: matrix.python-version != '3.12.0-alpha.5'
run: |
# Install to collect dependencies into the (pip) cache.
pip install .[test]
@@ -221,6 +230,7 @@ jobs:
&& startsWith(github.ref, 'refs/tags')
&& startsWith(runner.os, 'Mac')
&& !startsWith(matrix.python-version, 'pypy')
+ && !startsWith(matrix.python-version, '3.12.0-alpha.5')
env:
TWINE_PASSWORD: ${{ secrets.TWINE_PASSWORD }}
run: |
@@ -233,16 +243,17 @@ jobs:
fail-fast: false
matrix:
python-version:
- - "pypy-3.7"
+ - "pypy-3.9"
- "3.7"
- "3.8"
- "3.9"
- "3.10"
- "3.11"
+ - "3.12.0-alpha.5"
os: [ubuntu-20.04, macos-11]
exclude:
- os: macos-11
- python-version: "pypy-3.7"
+ python-version: "pypy-3.9"
steps:
- name: checkout
@@ -275,7 +286,22 @@ jobs:
with:
name: zope.i18nmessageid-${{ runner.os }}-${{ matrix.python-version }}.whl
path: dist/
+ - name: Install zope.i18nmessageid 3.12.0-alpha.5
+ if: ${{ startsWith(matrix.python-version, '3.12.0-alpha.5') }}
+ run: |
+ pip install -U wheel setuptools
+ # coverage has a wheel on PyPI for a future python version which is
+ # not ABI compatible with the current one, so build it from sdist:
+ pip install -U --no-binary :all: coverage
+ # Unzip into src/ so that testrunner can find the .so files
+ # when we ask it to load tests from that directory. This
+ # might also save some build time?
+ unzip -n dist/zope.i18nmessageid-*whl -d src
+ # Use "--pre" here because dependencies with support for this future
+ # Python release may only be available as pre-releases
+ pip install --pre -U -e .[test]
- name: Install zope.i18nmessageid
+ if: ${{ !startsWith(matrix.python-version, '3.12.0-alpha.5') }}
run: |
pip install -U wheel setuptools
pip install -U coverage
diff --git a/.manylinux-install.sh b/.manylinux-install.sh
index 73e5fe9..544f6a3 100755
--- a/.manylinux-install.sh
+++ b/.manylinux-install.sh
@@ -28,6 +28,7 @@ yum -y install libffi-devel
tox_env_map() {
case $1 in
+ *"cp312"*) echo 'py312';;
*"cp37"*) echo 'py37';;
*"cp38"*) echo 'py38';;
*"cp39"*) echo 'py39';;
@@ -40,13 +41,19 @@ tox_env_map() {
# Compile wheels
for PYBIN in /opt/python/*/bin; do
if \
+ [[ "${PYBIN}" == *"cp312"* ]] || \
[[ "${PYBIN}" == *"cp311"* ]] || \
[[ "${PYBIN}" == *"cp37"* ]] || \
[[ "${PYBIN}" == *"cp38"* ]] || \
[[ "${PYBIN}" == *"cp39"* ]] || \
[[ "${PYBIN}" == *"cp310"* ]] ; then
- "${PYBIN}/pip" install -e /io/
- "${PYBIN}/pip" wheel /io/ -w wheelhouse/
+ if [[ "${PYBIN}" == *"cp312"* ]] ; then
+ "${PYBIN}/pip" install --pre -e /io/
+ "${PYBIN}/pip" wheel /io/ --pre -w wheelhouse/
+ else
+ "${PYBIN}/pip" install -e /io/
+ "${PYBIN}/pip" wheel /io/ -w wheelhouse/
+ fi
if [ `uname -m` == 'aarch64' ]; then
cd /io/
${PYBIN}/pip install tox
diff --git a/.meta.toml b/.meta.toml
index 92b1a21..8d8ac44 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,13 +2,13 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "3c9d0741"
+commit-id = "1514f236"
[python]
with-appveyor = true
with-windows = false
with-pypy = true
-with-future-python = false
+with-future-python = true
with-docs = true
with-sphinx-doctests = true
with-macos = false
diff --git a/CHANGES.rst b/CHANGES.rst
index 229991d..8e5f5d2 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -7,6 +7,8 @@
- Drop support for Python 2.7, 3.5, 3.6.
+- Add preliminary support for Python 3.12a5.
+
5.1.1 (2022-11-17)
==================
diff --git a/appveyor.yml b/appveyor.yml
index 7d2b543..b209c91 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -14,6 +14,9 @@ environment:
- python: 39-x64
- python: 310-x64
- python: 311-x64
+ # `multibuild` cannot install non-final versions as they are not on
+ # ftp.python.org, so we skip Python 3.11 until its final release:
+ # - python: 312-x64
install:
- "SET PYTHONVERSION=%PYTHON%"
diff --git a/docs/narr.rst b/docs/narr.rst
index 52aa1cc..c844068 100644
--- a/docs/narr.rst
+++ b/docs/narr.rst
@@ -75,7 +75,7 @@ Messages at first seem like they are text strings:
.. doctest::
>>> import six
- >>> robot == u'robot-message'
+ >>> robot == 'robot-message'
True
>>> isinstance(robot, six.text_type)
True
@@ -85,7 +85,7 @@ through attributes:
.. doctest::
- >>> robot.default == u'${name} is a robot.'
+ >>> robot.default == '${name} is a robot.'
True
>>> robot.mapping
>>> robot.domain
@@ -106,24 +106,24 @@ object. They cannot be changed once the message id is created:
...
AttributeError: readonly attribute
- >>> robot.mapping = {u'name': u'Bender'}
+ >>> robot.mapping = {'name': 'Bender'}
Traceback (most recent call last):
...
AttributeError: readonly attribute
-If you need to change their information, you'll have to make a new
+If you need to change their information, yo'll have to make a new
message id object:
.. doctest::
- >>> new_robot = Message(robot, mapping={u'name': u'Bender'})
- >>> new_robot == u'robot-message'
+ >>> new_robot = Message(robot, mapping={'name': 'Bender'})
+ >>> new_robot == 'robot-message'
True
>>> new_robot.domain
'futurama'
- >>> new_robot.default == u'${name} is a robot.'
+ >>> new_robot.default == '${name} is a robot.'
True
- >>> new_robot.mapping == {u'name': u'Bender'}
+ >>> new_robot.mapping == {'name': 'Bender'}
True
Last but not least, messages are reduceable for pickling:
@@ -133,20 +133,20 @@ Last but not least, messages are reduceable for pickling:
>>> callable, args = new_robot.__reduce__()
>>> callable is Message
True
- >>> args == (u'robot-message',
+ >>> args == ('robot-message',
... 'futurama',
- ... u'${name} is a robot.',
- ... {u'name': u'Bender'},
+ ... '${name} is a robot.',
+ ... {'name': 'Bender'},
... None,
... None,
... None)
True
- >>> fembot = Message(u'fembot')
+ >>> fembot = Message('fembot')
>>> callable, args = fembot.__reduce__()
>>> callable is Message
True
- >>> args == (u'fembot', None, None, None, None, None, None)
+ >>> args == ('fembot', None, None, None, None, None, None)
True
Pickling and unpickling works, which means we can store message IDs in
@@ -160,10 +160,10 @@ a database:
>>> (pickle_bot,
... pickle_bot.domain,
... pickle_bot.default,
- ... pickle_bot.mapping) == (u'robot-message',
+ ... pickle_bot.mapping) == ('robot-message',
... 'futurama',
- ... u'${name} is a robot.',
- ... {u'name': u'Bender'})
+ ... '${name} is a robot.',
+ ... {'name': 'Bender'})
True
>>> pickle_bot.__reduce__()[0] is Message
True
diff --git a/setup.cfg b/setup.cfg
index fdfa80f..768d60e 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -23,7 +23,7 @@ ignore =
force_single_line = True
combine_as_imports = True
sections = FUTURE,STDLIB,THIRDPARTY,ZOPE,FIRSTPARTY,LOCALFOLDER
-known_third_party = six, docutils, pkg_resources
+known_third_party = six, docutils, pkg_resources, pytz
known_zope =
known_first_party =
default_section = ZOPE
diff --git a/tox.ini b/tox.ini
index f182c06..df39aa5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
# Generated from:
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[tox]
-minversion = 3.18
+minversion = 4.0
envlist =
lint
py37,py37-pure
@@ -9,13 +9,16 @@ envlist =
py39,py39-pure
py310,py310-pure
py311,py311-pure
+ py312,py312-pure
pypy3
docs
coverage
[testenv]
usedevelop = true
+pip_pre = py312: true
deps =
+ Sphinx
setenv =
pure: PURE_PYTHON=1
!pure-!pypy3: PURE_PYTHON=0