summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Gedminas <marius@gedmin.as>2019-11-12 09:49:09 +0200
committerMarius Gedminas <marius@gedmin.as>2019-11-12 09:49:09 +0200
commit9d4230e088c848b7a355e06253956c765e7c7470 (patch)
treeb57ed11ba2d254fc8097f7725458a6b29a02ce6c
parente906781e4539a5276fa9917ccb5d9b9ff2f33d58 (diff)
downloadzope-i18nmessageid-9d4230e088c848b7a355e06253956c765e7c7470.tar.gz
Add support for Python 3.8
Also let's use the latest floating PyPy versions on Travis CI.
-rw-r--r--.travis.yml23
-rw-r--r--CHANGES.rst2
-rw-r--r--appveyor.yml2
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
5 files changed, 18 insertions, 12 deletions
diff --git a/.travis.yml b/.travis.yml
index 9244184..05c149d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,27 +1,28 @@
language: python
-dist: xenial
+
python:
- 2.7
- 3.5
- 3.6
- 3.7
- - pypy2.7-6.0.0
- - pypy3.5-6.0.0
-script:
- - coverage run -m zope.testrunner --test-path=src --auto-color --auto-progress
-
-after_success:
- - coveralls
-notifications:
- email: false
+ - 3.8
+ - pypy
+ - pypy3
install:
- pip install -U pip setuptools
- pip install -U coveralls coverage zope.testrunner
- pip install -U -e ".[test]"
+script:
+ - coverage run -m zope.testrunner --test-path=src --auto-color --auto-progress
-cache: pip
+after_success:
+ - coveralls
+notifications:
+ email: false
+
+cache: pip
before_cache:
- rm -f $HOME/.cache/pip/log/debug.log
diff --git a/CHANGES.rst b/CHANGES.rst
index 39e7fbc..14227b1 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -7,6 +7,8 @@
- Drop support for Python 3.4.
+- Add support for Python 3.8.
+
4.3.1 (2018-10-19)
==================
diff --git a/appveyor.yml b/appveyor.yml
index 2913229..25cf34a 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -13,6 +13,8 @@ environment:
- python: 36-x64
- python: 37
- python: 37-x64
+ - python: 38
+ - python: 38-x64
install:
- "SET PATH=C:\\Python%PYTHON%;c:\\Python%PYTHON%\\scripts;%PATH%"
diff --git a/setup.py b/setup.py
index dea33ec..9931a10 100644
--- a/setup.py
+++ b/setup.py
@@ -123,6 +123,7 @@ setup(
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 78b2a54..7ee9522 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py35,py36,py37,pypy,pypy3,coverage,docs
+ py27,py35,py36,py37,py38,pypy,pypy3,coverage,docs
[testenv]
deps =