summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2012-04-06 22:48:32 +0000
committerTres Seaver <tseaver@palladion.com>2012-04-06 22:48:32 +0000
commit74abb7342c96549aff85ec2821f20211746ad2ea (patch)
tree2296aeb708bd5780c2af47bdd5a61e6fccf6ba8b
parent400db7486983c03bb8ad373f13578777b031138a (diff)
downloadzope-i18nmessageid-74abb7342c96549aff85ec2821f20211746ad2ea.tar.gz
Added 'setup.py dev' alias:
- Runs ``setup.py develop`` - Installs ``nose`` and ``coverage`` Add 'setup.py docs' alias: - Installs ``Sphinx`` and dependencies.
-rw-r--r--CHANGES.txt5
-rw-r--r--setup.cfg11
-rw-r--r--setup.py24
3 files changed, 28 insertions, 12 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index f6f9d28..8517765 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -5,6 +5,11 @@ CHANGES
3.6.2 (unreleased)
------------------
+- Added 'setup.py dev' alias (runs ``setup.py develop`` plus installs
+ ``nose`` and ``coverage``).
+
+- Added 'setup.py docs' alias (installs ``Sphinx`` and dependencies).
+
3.6.1 (2011-07-20)
------------------
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..2989773
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,11 @@
+[nosetests]
+nocapture=1
+cover-package=zope.i18nmessageid
+cover-erase=1
+with-doctest=0
+where=src
+
+[aliases]
+dev = develop easy_install zope.i18nmessageid[testing]
+docs = easy_install zope.i18nmessageid[docs]
+
diff --git a/setup.py b/setup.py
index 0bfe075..ef8dad6 100644
--- a/setup.py
+++ b/setup.py
@@ -43,21 +43,22 @@ codeoptimization = Feature(
[os.path.normcase(codeoptimization_c)]
)])
-if is_pypy or is_jython:
+extra = {
+ 'extras_require': {'testing': ['nose', 'coverage'],
+ 'docs': ['Sphinx'],
+ },
+}
+
+if not is_pypy and not is_jython:
# Jython cannot build the C optimizations, while on PyPy they are
# anti-optimizations (the C extension compatibility layer is known-slow,
# and defeats JIT opportunities).
- extra = {}
-else:
- extra = {'features':{'codeoptimization':codeoptimization}}
+ extra['features'] = {'codeoptimization':codeoptimization}
if sys.version_info >= (3,):
- extra.update(dict(use_2to3 = True,
- convert_2to3_doctests = [
- 'src/zope/i18nmessageid/messages.txt',
- ],
- )
- )
+ extra['use_2to3'] = True
+ extra['convert_2to3_doctests'] = ['src/zope/i18nmessageid/messages.txt',
+ ]
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
@@ -98,7 +99,6 @@ class optional_build_ext(build_ext):
sys.stderr.write(str(e) + '\n')
sys.stderr.write('*' * 80 + '\n')
-
setup(name='zope.i18nmessageid',
version = '3.6.2dev',
author='Zope Foundation and Contributors',
@@ -140,5 +140,5 @@ setup(name='zope.i18nmessageid',
zip_safe = False,
cmdclass = {'build_ext':optional_build_ext},
**extra
- )
+)