summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2015-01-12 09:14:12 -0500
committerTres Seaver <tseaver@palladion.com>2015-01-12 09:14:21 -0500
commit5107f4a64e115d3bbd41203cee95f7dd9a88e965 (patch)
tree5ec5b80a8c716268dfb2b188564ee43d740831c3
parent4b27cb1151030ad9004c4d7311cd442ac8914b69 (diff)
downloadzope-i18nmessageid-5107f4a64e115d3bbd41203cee95f7dd9a88e965.tar.gz
Update hacking docs to reflect Github.
[ci skip]
-rw-r--r--docs/hacking.rst96
1 files changed, 54 insertions, 42 deletions
diff --git a/docs/hacking.rst b/docs/hacking.rst
index 7a26e86..e1be797 100644
--- a/docs/hacking.rst
+++ b/docs/hacking.rst
@@ -3,18 +3,24 @@ Hacking on :mod:`zope.i18nmessageid`
Getting the Code
------------------
+################
+
+The main repository for :mod:`zope.i18nmessageid` is in the Zope Foundation
+Github repository:
+
+ https://github.com/zopefoundation/zope.i18nmessageid
+
+You can get a read-only checkout from there:
-The main repository for :mod:`zope.i18nmessageid` is in the Zope Subversion
-repository:
+.. code-block:: sh
-http://svn.zope.org/zope.8nmessageid
+ $ git clone https://github.com/zopefoundation/zope.i18nmessageid.git
-You can get a read-only Subversion checkout from there:
+or fork it and get a writeable checkout of your fork:
.. code-block:: sh
- $ svn checkout svn://svn.zope.org/repos/main/zope.8nmessageid/trunk zope.i8nmessageid
+ $ git clone git@github.com/jrandom/zope.i18nmessageid.git
The project also mirrors the trunk from the Subversion repository as a
Bazaar branch on Launchpad:
@@ -28,8 +34,12 @@ You can branch the trunk from there using Bazaar:
$ bzr branch lp:zope.i8nmessageid
-Running the tests in a ``virtualenv``
--------------------------------------
+
+Working in a ``virtualenv``
+###########################
+
+Installing
+----------
If you use the ``virtualenv`` package to create lightweight Python
development environments, you can run the tests using nothing more
@@ -47,7 +57,10 @@ environment:
$ /tmp/hack-zope.i8nmessageid/bin/python setup.py develop
-Finally, run the tests using the build-in ``setuptools`` testrunner:
+Running the tests
+-----------------
+
+Run the tests using the build-in ``setuptools`` testrunner:
.. code-block:: sh
@@ -93,8 +106,8 @@ you can see how well the tests cover the code:
OK
-Building the documentation in a ``virtualenv``
-----------------------------------------------
+Building the documentation
+--------------------------
:mod:`zope.i18nmessageid` uses the nifty :mod:`Sphinx` documentation system
for building its docs. Using the same virtualenv you set up to run the
@@ -134,8 +147,11 @@ You can also test the code snippets in the documentation:
build succeeded.
-Running the tests using :mod:`zc.buildout`
--------------------------------------------
+Using :mod:`zc.buildout`
+########################
+
+Setting up the buildout
+-----------------------
:mod:`zope.i18nmessageid` ships with its own :file:`buildout.cfg` file and
:file:`bootstrap.py` for setting up a development buildout:
@@ -151,6 +167,10 @@ Running the tests using :mod:`zc.buildout`
Generated script '.../bin/sphinx-quickstart'.
Generated script '.../bin/sphinx-build'.
+
+Running the tests
+-----------------
+
You can now run the tests:
.. code-block:: sh
@@ -163,8 +183,8 @@ You can now run the tests:
Tear down zope.testing.testrunner.layer.UnitTests in 0.000 seconds.
-Building the documentation using :mod:`zc.buildout`
----------------------------------------------------
+Building the documentation
+--------------------------
The :mod:`zope.i18nmessageid` buildout installs the Sphinx scripts required to
build the documentation, including testing its code snippets:
@@ -200,8 +220,12 @@ build the documentation, including testing its code snippets:
Build finished. The HTML pages are in .../docs/_build/html.
-Running Tests on Multiple Python Versions via :mod:`tox`
---------------------------------------------------------
+Using :mod:`tox`
+################
+
+
+Running Tests on Multiple Python Versions
+-----------------------------------------
`tox <http://tox.testrun.org/latest/>`_ is a Python-based test automation
tool designed to run tests against multiple Python versions. It creates
@@ -212,19 +236,8 @@ configured commands.
:mod:`zope.i18nmessageid` configures the following :mod:`tox` environments via
its ``tox.ini`` file:
-- The ``py26`` environment builds a ``virtualenv`` with ``python2.6``,
- installs :mod:`zope.i18nmessageid` and dependencies, and runs the tests
- via ``python setup.py test -q``.
-
-- The ``py27`` environment builds a ``virtualenv`` with ``python2.7``,
- installs :mod:`zope.i18nmessageid` and dependencies, and runs the tests
- via ``python setup.py test -q``.
-
-- The ``py32`` environment builds a ``virtualenv`` with ``python3.2``,
- installs :mod:`zope.i18nmessageid` and dependencies, and runs the tests
- via ``python setup.py test -q``.
-
-- The ``pypy`` environment builds a ``virtualenv`` with ``pypy``,
+- The ``py26``, ``py27``, ``py33``, ``py34``, and ``pypy`` environments
+ builds a ``virtualenv`` with ``pypy``,
installs :mod:`zope.i18nmessageid` and dependencies, and runs the tests
via ``python setup.py test -q``.
@@ -282,16 +295,19 @@ including building the docs and testing their snippets:
congratulations :)
+
+Contributing to :mod:`zope.i18nmessageid`
+#################################
+
Submitting a Bug Report
-----------------------
-:mod:`zope.i18nmessageid` tracks its bugs on Launchpad:
+:mod:`zope.i18nmessageid` tracks its bugs on Github:
-https://bugs.launchpad.net/zope.i18nmessageid
+ https://github.com/zopefoundation/zope.i18nmessageid/issues
Please submit bug reports and feature requests there.
-
Sharing Your Changes
--------------------
@@ -302,16 +318,12 @@ Sharing Your Changes
or bug fixes, although it is possible that you may have tested your
new code by updating existing tests.
-If you got a read-only checkout from the Subversion repository, and you
-have made a change you would like to share, the best route is to let
-Subversion help you make a patch file:
-
-.. code-block:: sh
-
- $ svn diff > zope.i18nmessageid-cool_feature.patch
+If have made a change you would like to share, the best route is to fork
+the Githb repository, check out your fork, make your changes on a branch
+in your fork, and push it. You can then submit a pull request from your
+branch:
-You can then upload that patch file as an attachment to a Launchpad bug
-report.
+ https://github.com/zopefoundation/zope.i18nmessageid/pulls
If you branched the code from Launchpad using Bazaar, you have another
option: you can "push" your branch to Launchpad: