summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Vagelpohl <jens@plyp.com>2022-11-17 15:27:19 +0100
committerJens Vagelpohl <jens@plyp.com>2022-11-17 15:27:19 +0100
commit1212ab25b31c7b34d24376464d0d05f496dd91bb (patch)
treea92b35333993c93a157f5e394842ec19f0a50a9b
parentcfed1fcde83b26cb410ceb01720a5751ad49f704 (diff)
downloadzope-i18nmessageid-1212ab25b31c7b34d24376464d0d05f496dd91bb.tar.gz
- prepare release 5.1.15.1.1
-rw-r--r--.github/workflows/tests.yml1
-rw-r--r--.meta.toml3
-rw-r--r--CHANGES.rst4
-rw-r--r--setup.py2
4 files changed, 6 insertions, 4 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 4899b9f..0cca637 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -317,6 +317,7 @@ jobs:
pip install -U wheel setuptools
pip install -U coverage
pip install -U 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"'
+ pip install -U 'cffi; platform_python_implementation == "CPython"'
# Unzip into src/ so that testrunner can find the .so files
# when we ask it to load tests from that directory. This
# might also save some build time?
diff --git a/.meta.toml b/.meta.toml
index f74e092..30ce2b2 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "57e4030390098babcc18db626cc426388394c231"
+commit-id = "342271a70d886e753e5cc629e8a81b3cfab692ac"
[python]
with-appveyor = true
@@ -12,6 +12,7 @@ with-future-python = false
with-legacy-python = true
with-docs = true
with-sphinx-doctests = true
+with-macos = false
[tox]
use-flake8 = true
diff --git a/CHANGES.rst b/CHANGES.rst
index a8ab3d3..3d6005c 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -2,8 +2,8 @@
Changes
=========
-5.11 (unreleased)
-=================
+5.1.1 (2022-11-17)
+==================
- Add support for building arm64 wheels on macOS.
diff --git a/setup.py b/setup.py
index fb2f36c..26fa7cc 100644
--- a/setup.py
+++ b/setup.py
@@ -96,7 +96,7 @@ class optional_build_ext(build_ext):
setup(
name='zope.i18nmessageid',
- version='5.1.1.dev0',
+ version='5.1.1',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Message Identifiers for internationalization',